Getting half the FPS when running 2 RTSP camera on Xavier NX

Setup -

  • Jetson Xavier NX Module
  • Jetpack 4.4.x
  • Deepstream 5.0 + Deepstream Python Binding
  • RTSP Camera via network

Using Deepstream Python Test 3 as an example, I tried to run 2 streams from RTSP cameras. And compared to the 1 camera setup, the FPS was halved exactly.

I was curious if this is an expected behavior or if I missed a step somewhere. Based on examples I have seen on the NVIDIA’s website and the Test 1, it seemed like NX had no problem processing multiple streams.

I am attaching 2 logs that I exported when they were starting. If any feedback can be shared, it would be appreciated!


2_cameras_nx.txt (10.7 KB) 1_camera_nx.txt (2.6 KB)

Please run sudo tegrastats and attach the result for reference. Check if GPU loading is at ~100%.


Later today, I will run the process with 2 cameras attach and check using
sudo tegrastats
And report the result back here. Thanks for the quick response


Thanks again for the quick response.

I tried it and it seems to work fine. i think it may been the clock mode. I am running on 15W 6 Core now. Another issue popped up though.

For dev kit, I was able to successfully run it with no performance degradation.
However, using the production setting as mentioned below, I am getting the silent failure -

  • Jetson Xavier NX SoM
  • Jetpack 4.4.x
  • CTI Quark Carrier board
  • CTI (ConnectTech) BSP and Deepstream SDK installed on MicroSD card
  • Deepstream 5.0 + Deepstream Python Binding
  • RTSP Camera via network
  • AWS Greengrass SDK

This carrier board is a headless board. I have it connected via UART connector to see output, and I run the deepstream-test3 (Python). I also connected to it using SSH to run the script.

It seems to load fine but then it silently fails and i noticed that the board restarts (based on the output from UART). I am attaching the log from the app.

Would you be able to share some feedback on why this may be happening? Or would you have any pointer on how I can get better logs?


2_cam_log.txt (3.7 KB)

By default it is nveglglessink in deepstream-test3. If your board does not have display port,you may change to fakesink and try.