Getting problem in running Shmoo package

Hi!
I have made a custom board using TK1 and now i am going to run shmoo package but when i run the test, myphidget.exe crashed.
I have this phidget kit for testing
https://www.phidgets.com/?tier=3&catid=46&pcid=39&prodid=1020
I have tested it separately by running its utility. I tried to copy the Phidget21.NET.dll in shmoo folder but it seems no working.
can anyone know the solution for this problem.
Thank You

Hi, did you download Phidget driver 2.1 or later(available at http://www.phidgets.com/drivers.php) used to
control the Phidget for device power on & off and reset signals. ?

Yes i have downloaded and i can control relays using it separately. But when i run the test, phidget.exe crashes.

Are you using the phidget.exe in shmoo package to control it separately?

Yes

Not sure why this happen, it should be OK since no problem to run separately…

You can check the pmu.py in folder /core in package to see if any clue on this.

Ok, i will check and also i will show snapshot of error i am getting.

I am getting this error:
MyPhidget has stopped working
in Description of error:
Description:
Stopped working

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: phidget.exe
Problem Signature 02: 1.0.0.0
Problem Signature 03: 4f26e871
Problem Signature 04: phidget
Problem Signature 05: 1.0.0.0
Problem Signature 06: 4f26e871
Problem Signature 07: 2
Problem Signature 08: 2bc
Problem Signature 09: System.BadImageFormatException
OS Version: 6.1.7601.2.1.0.256.1
Locale ID: 1033

Read our privacy statement online:
http://go.microsoft.com/fwlink/?linkid=104288&clcid=0x0409

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt
can you guess what is the problem?

Actually, it is also not working when I run it separately in shmoo package. I am testing it from the separately installed library that is available on www.phidgets.com.

No clue about it, looks like a OS compatible issue…seems you need to ask Phidgets for help.

It worked, I installed the phidget library for very older version available here

https://www.phidgets.com/downloads/phidget21/libraries/windows/Phidget-x64/

Thanks for your help