Getting python error while flasing the Nvidia device

Traceback (most recent call last):

File “/home/kathiravanl4t/L4T_dev/L4T_bsp/Linux_for_Tegra/bootloader/./”, line 1281, in


File “/home/kathiravanl4t/L4T_dev/L4T_bsp/Linux_for_Tegra/bootloader/./”, line 1150, in tegraflash_run_commands


File “/usr/lib/python3.10/”, line 217, in onecmd

return func(arg)

File “/home/kathiravan/l4t/L4T_dev/L4T_bsp/Linux_for_Tegra/bootloader/./”, line 779, in do_dump

tegraflash_dump(exports, args)

File “/home/kathiravanl4t/L4T_dev/L4T_bsp/Linux_for_Tegra/bootloader/”, line 1246, in tegraflash_dump

tegraflash_dumpeeprom(args, dump_args[1:])

File “/home/kathiravan/4t/L4T_dev/L4T_bsp/Linux_for_Tegra/bootloader/”, line 1300, in tegraflash_dumpeeprom


File “/home/kathiravan/L4T_bsp/Linux_for_Tegra/bootloader/”, line 2350, in tegraflash_boot_mb2_applet

filename = tegraflash_send_mb2_applet()

File “/home/kathiravan//l4t/L4T_dev/L4T_bsp/Linux_for_Tegra/bootloader/”, line 2344, in tegraflash_send_mb2_applet

filename = tegraflas_oem_sign_file(filename, 'PLDT')

File “/home/kathiravan//l4t/L4T_dev/L4T_bsp/Linux_for_Tegra/bootloader/”, line 2109, in tegraflas_oem_sign_file

for file_nodes in xml_tree.getiterator('file'):

AttributeError: ‘ElementTree’ object has no attribute ‘getiterator’

Reading board information failed.

i am getting above error and i changed python to 3.10 in that time also i am getting the same error.

can anyone please help me to identify and slove the problem.

after below state i am getting above error.
2.5070 ] tegrasign_v2 --key None --list nvtboot_applet_t194_sigheader.bin_list.xml --pubkeyhash pub_key.key

[ 2.5087 ] Assuming zero filled SBK key

[ 2.5183 ]


There is no update from you for a period, assuming this is not an issue any more.
Hence we are closing this topic. If need further support, please open a new one.

Hi kathiravan,

The logs above looks like caused from environment issue.
And you could just provide the flash log file and upload here.

Are you using standalone Ubuntu18.04 as your host PC

Are you using the devkit or custom board?

If you are using the devkit, have you tried to flash with SDKM?

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.