Getting "Unable to Load the nvidia-drm kernel module" message while trying to install Linux driver 470.86


I have an Gigabyte GeForce RTX 3080 Ti Aorus Master GPU.

I am trying to use this GPU for mining using HiveOS. Fresh install of HiveOS does not recognize the GPU. It is shown as:

GA 102 [GeForce RTX 3080 Ti]

in HiveOS web user interface.

When I try to install latest NVidia Driver for HiveOS using nvidia-driver-update --force command, I am getting “driver installation failed” error.

Checking /var/log/nvidia-installer.log" file using
tail -n 200 /var/log/nvidia-installer.log command reveals following info:

ERROR: Unable to load the ‘nvidia-drm’ kernel module.

please see problem_details file attached.

I am unable to use the GPU for mining. I have been searching for a solution for last 1 week with no luck. Please help me to find a solution for this stubborn problem.

Thanks in advance,

Might be secure boot enabled or nouveau is loading or something different.
Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post.

Hi, did you resolve this problem?

I picked up a brand new 3060Ti FE from BestBuy and it’s giving me the same error in HiveOS.

My specifications:
Rebtech Mining Motherboard
3060Ti FE
470.86 Drivers

I tried updating/downgrading my drivers but I get the same exact errors as you. My card just displays the SAME exact thing as thing as your HiveOS photo. It won’t mine or apply OCs, or anything. :/ I’ve never had this issue with any of my other 26 cards.

Hi, no solution so far. I am trying to obtain RMA authorization to have it fixed under warranty. Paid 2200+ usd on this card and could not use it, super frustrating.

Sorry to hear, I actually just “fixed” it on my end (kind of). I swapped the card as-is over to my existing working Rebtech mining board and it recognized it instantly. My two new boards did not recognize it, so I have I think there’s a setting that needs to be enabled/disabled on the new Rebtech boards.

I know for your situation, you’re not using the Rebtech boards but perhaps you need to disable/enable some settings in your motherboard for it to recognize your GPU.

I read here that the iGPU needs to be disabled along with other settings. I will have to play around with that on my new Rebtech motherboards.

I hope this helps!