Getting "Unsupported ABI version" error for optix 7.4 code built with cuda 11.3 and driver 510.73.05

Dear forum, my students and I are trying to implement a voxel-based photon simulator (basically a barebone version to our CUDA based code at GitHub - fangq/mcx: Monte Carlo eXtreme (MCX) - GPU-accelerated photon transport simulator) using OptiX 7.4.

The code runs fine on Windows built with Visual studio, but when I try to compile it using a Makefile on Linux, I am getting the below error

A runtime error occured.
An Optix runtime error occurred:
'Unsupported ABI version'
 at (../mcx-optix-host/mcx_context.cpp:99)

the referenced code line is OPTIX_CHECK(optixInit());

I tried several machines, running Ubuntu 18.04 or 20.04, over various versions of drivers ranging from 470.129 to 510.73.05, and also tried CUDA 11.3 and 10.2, all of them ended with the same error.

I am wondering if you have any suggestion how to solve this. From my google search, it seems this may be more related to driver version, but I thought my machine with 510.73 on Ubuntu 20.04 should be new enough.

any suggestion is appreciated!

Hi @FangQ,

Do the OptiX SDK samples build and run without error on Linux, or are you getting the same issue there?