Getting wrong result after TLT-convert on jetson

Hi,
We are done classification training on 2080Ti and generate etlt and trt when we test result of generated trt ,It was give above 80% good result on video on 2080Ti but ,We convert etlt file in engine file via tlt-converter on xavier NX it give bad result on same video ,Please help us to resolve this problem and find the reason why result is bad on xavier NX below is my some configuration

Deepstream 5.0

Training Env : 2080Ti , TLT container nvcr.io/nvidia/tlt-streamanalytics:v2.0_py3

Testing Env : jetson Xavier NX, jetpack 4.4

command using for tlt convet (tlt_7.1) on jetson xavier NX:

./tlt-converter -k 'abcd1234' -c age_classification.bin -d 3,224,224 -o predictions/Softmax -e ./age_classification_int8.engine -i nchw -m 64 -b 64 -t int8 ./age_classification.etlt

testing via deepstream 5.0 on both Env (2080Ti and xavier NX) and same config file using below is details of config file,

[property]
gpu-id=0
net-scale-factor=1
model-engine-file=./Model/age_classification_int8.engine         (For Xavier NX)
#model-engine-file=./Model/age_classification.trt         (for 2080 TI)
labelfile-path=./Model/age_classification.txt
batch-size=1
network-mode=1
input-object-min-width=0
input-object-min-height=0
process-mode=2
model-color-format=1
gpu-id=0
gie-unique-id=4
operate-on-gie-id=1
operate-on-class-ids=0
is-classifier=1
output-blob-names=predictions/Softmax
classifier-async-mode=0
classifier-threshold=0.50

Hi @thakur.sandeep.srs,
TLT team should be able to support you better here.
Request you to raise your concern here
https://forums.developer.nvidia.com/c/accelerated-computing/intelligent-video-analytics/transfer-learning-toolkit/17

Thanks!