Ghosting - previous objects shapes on new render

Hello folks,
Does anybody know how to get rid of the “ghost” objects that were present in previous renders but their shape is somehow still present in next render iterations?
I am trying to get rid of those in order to get clean images for offline data generation.

Running the offline dataset generator script (3. Offline Dataset Generation — Omniverse Robotics documentation) or running the render directly from Isaac gives the same result.

That’s the result after 9 iterations of viewport generation:

Disabling AO: Aggressive denoising makes the ghosting last for even longer. So I would assume that the denoising somehow has to be increased even more.
I followed the suggestion from Ghosting in the viewport rendering - #4 by cornibert , but that didn’t help.

Regards

Hello,

It does look like what you can currently expect when Sampled Lighting is enabled in the Ray Tracing/Direct Lighting settings, if Shadows are enabled. This will be improved in the future. In a scene with few lights, keeping Sampled Lighting disabled is usually preferable.

I disabled sampled lighting but that did not help.
The only way I can think of is changing the rendering mode, but that’s not what I am searching for.

The only way to remove ghosting is to increase settle latency in the rendering settings in the movie recorder. The more frame “settles” the less ghosting you can expect.