GIE cannot be installed on device

Hi,

I was trying to install JetPack on my TX2, however, during the post-installation phrase, following error were shown:

Error: GIE cannot be installed on device. This may be caused … make sure following packages are installed correctly on device before continuing:

libgie1 libgie-dev
After these packages are installed on device, press Enter key to continue

I manually installed libgie-dev successfully, however, libgie1 was unable to be installed manually.

Any idea the problem was ?

Thanks!

Hi,

This may be caused by our server crash at Tuesday.
We have fixed this issue and JetPack work properly now.

Please restart JetPack and re-install tensorRT again.
Thanks and sorry for the inconvenience.

Hi AastaLLL,

I have met the same problem, and many other users have reported the same issue. It is already discussed in the following ticket:

https://devtalk.nvidia.com/default/topic/1010129/jetson-tx1/e-unable-to-locate-package-libgie1/

I believe it is not related with the server. Please help to look into it. I cannot continue my work without have libgie1 installed.

Thanks,
FZ

Hi,

We are really sorry about this issue.
Our server is broken at Tuesday and it can lead to some error downloading.

If you have accessed JetPack3.1 before, please remove all the downloaded file and restart JetPack again.
We are monitoring our server status now. Please let us know if you still met error.

AastaLLL,

I have done so for several times since yesterday. It cannot help.

FZ

Hi,

Sorry for the issue.
We have checked this issue internally. Will update information to you later.

Really sorry about this.

AastaLLL,

Could you confirm where libgie1 package come from during the installation? It should be found within nv-gie-repo-ubuntu1604-rc-cuda8.0-trt2.1-20170328_1-1_arm64.deb. Right? But I cannot find it from the downloaded .deb file.

Here:

http://developer.download.nvidia.com/devzone/devcenter/mobile/jetpack_l4t/006/linux-x64/nv-gie-repo-ubuntu1604-6-rc-cuda8.0_1.0.2-1_arm64.deb

Thanks, I will have a try. At least I can see the libgie1 package in your .deb now.

AastaLLL,
I have successfully brought up the system and run the demo. Thank you for your support!

@AastaLLL, I tried again and still encounter the same problem with the exact same error message. It doesn’t seem to be related to the server crash issue that you mentioned. Could you please take a close look. We are stuck here and we really need to evaluate tx2 urgently.

By the way, it would be nice if Tx2 is preinstalled with JetPack and we, the customer, does not need to go through the trouble to setup.
Thanks.

I think the reason this is not pre-installed is because the uses for the Jetson can be quite different from person to person and an embedded system simply doesn’t have all the space a desktop PC has. Add to this that sometimes it is better to let the end user add on software just so the distributor does not need to deal with licensing (e.g., when you go to flash the Ubuntu file system the NVIDIA-provided direct hardware access files are added separately by the person doing the flash…it’s up to the end user to make the choice to mix them). Even if this software were pre-installed almost nobody would keep the original install due to bug fixes (most everyone would be flashing anyway).

NOTE: JetPack itself only installs to the host PC, though extra packages are convenient to add through JetPack.

Hi chenxuan,

Sorry for the inconvenience.

This issue is related to our server crash last week.
Although we fixed this in hours, some local server have cached the broken version until cache expires.

From topic 1010075, this issue is fixed recently (broken version no available any more)
https://devtalk.nvidia.com/default/topic/1010075/jetson-tx2/jetpack-3-0-installing-visionworks-error-29/post/5156806/#5156806

Please re-download JetPack and reinstall in again.
By default, tensorRT will be installed after image is flashed. It won’t need any manually command to make it installed.

Please try it again and let us know the result.
Thanks and sorry for the inconvenience.