__GL_THREADED_OPTIMIZATIONS=1 and glBufferSubDataARB crashes with drivers newer than 313.09

Hello,

I am using wine to play World of Warcraft on a GTX 460. This works mostly flawlessly, especially with the new threaded optimizations, which turn out to work very well in conjunction with wine/WoW.

I am using wine with the unoffical glBufferSubDataARB patch (see http://bugs.winehq.org/attachment.cgi?id=42868&action=diff) which gives a great performance gain (30% from threaded optimizations and another 30% from using glBufferSubDataARB for dynamic buffer uploads). Originally this patch was for wine-1.5.20, but it applies (and works) cleanly with all versions after that.

Now the combination of nvidia-313.09, patched wine and threaded optimizations works rock solid (many hours of 3D gaming without problems) and gives a very high performance compared to the baseline.

Unfortunately if I replace the driver with something newer like 313.18 oder 313.26 wow/wine crashes a few seconds after start. If I omit “__GL_THREADED_OPTIMIZATIONS=1” it runs for a few minutes, but usually crashes after the first zone change. There is no useful crash information (yet), just a crash to desktop and a wine/windows error (Attempt to access 0x00000000 etc.)

Edit: These crashes happen only in D3D mode, start it with “__GL_THREADED_OPTIMIZATIONS=1 WINEDEBUG=-all wine wow -d3d9”
[This file was removed because it was flagged as potentially malicious] (62.2 KB)

I can confirm that issue with Starcraft 2. It works great with the mentioned patch and threading enabled with driver up to 313.09.

With all newer drivers i have random crashes back to dekstop.

Please fix this issue as the threading optimization with the mentioned wine patch gives a huge speed boost for MANY games.

Getting this issue fix is also a necessary step for getting the patch into mainline wine.

Many thanks,
Christian

hirschhornsalz / christian_frank, Please provide nvidia bug report and reproduction steps .

  1. Download wine 1.5.25 ( wget http://mirrors.ibiblio.org/wine/source/1.5/wine-1.5.25.tar.bz2 )
  2. Download the patch ( wget -O buffer.patch http://bugs.winehq.org/attachment.cgi?id=42868&action=diff&context=patch&collapsed=&headers=1&format=raw )
  3. unpack and patch (tar xf wine-1.5.25.tar.bz2; cd wine-1.5.25; patch -p1 < …/buffer.patch)
  4. build and install patched wine (./configure;make;make install - maybe choose a different PREFIX with configure)
  5. Execute WoW from the “World of Warcraft” directory using this command: __GL_THREADED_OPTIMIZATIONS=1 WINEDEBUG=-all wine wow -d3d9

The “WINEDEBUG=-all” is needed for avoiding calling glError() after each opengl command, the “-d3d9” switch tells WoW to start in directx9 mode.
Shortly after (or during) logging in WoW will crash if using a recent driver, but with the 313.09 it will run very solid (and with high performance).

This assumes you have access to a World of Warcraft installation. A copy from a Windows install will usually do fine.

Thanks for reporting this. I filed bug 1254446 to track trying to reproduce the problem.

Hi,

find attached my bug report.
Follow the steps hirschhornsalz described and start startcraft 2 with with patched executable.
In Sc2 its harder to debug cause the crashes happen from time to time while playing. Sometimes in the first game, sometimes after 5 games.

[This file was removed because it was flagged as potentially malicious] (86.6 KB)

Playing the hots campaing i noticed that the crashes back to dekstop will happen very frequently, so you should notice it very easily.

hirschhornsalz, christian_frank ,

Please attach nvidia bug report

The very first post has my nvidia bug report attached. It shows up as “[Scanning please wait]” since a wekk ;-) Here it is again in case there is a problem with the forum software.
[This file was removed because it was flagged as potentially malicious] (62.2 KB)

My bug report was attached to the post before my last one.
Here it is again.
[This file was removed because it was flagged as potentially malicious] (86.6 KB)

any news on this issue ?

No news yet, sorry.

hirschhornsalz, Which patch of World of Warcraft you are using like (Cataclysm OR Mists Pandaria) ? What Level your playing in? Is there any game settings required?

I am using Mists of Pandaria. I am using the “directcx9” renderer, AFAIK World of Warcraft defaults to this. Game settings are everything to Ultra, but SSAO and sun casting disabled and shadows to medium. 4xAA and 16x Anisotropic.

My config.wtf:

SET locale “deDE”
SET installLocale “enUS”
SET hwDetect “0”
SET videoOptionsVersion “5”
SET gxApi “D3D9”
SET gxWindow “1”
SET gxMaximize “1”
SET Gamma “1.000000”
SET readTOS “1”
SET readEULA “1”
SET readTerminationWithoutNotice “1”
SET readScanning “1”
SET Sound_MusicVolume “0.40000000596046”
SET Sound_AmbienceVolume “0.40000000596046”
SET farclip “1300”
SET groundEffectDensity “128”
SET groundEffectDist “260”
SET terrainLodDist “650”
SET graphicsQuality “3”
SET textureFilteringMode “5”
SET accountName xxxxxxxxxxxxxxxxxxxxxxx
SET accounttype “MP”
SET projectedTextures “1”
SET enterWorld “1”
SET mouseSpeed “1”
SET ChatMusicVolume “0.29999998211861”
SET ChatSoundVolume “0.39999997615814”
SET ChatAmbienceVolume “0.29999998211861”
SET VoiceActivationSensitivity “0.39999997615814”
SET Sound_MasterVolume “0.10000000149012”
SET Sound_SFXVolume “0.40000000596046”
SET gameTip “36”
SET Sound_EnableSoundWhenGameIsInBG “1”
SET Sound_OutputQuality “2”
SET Sound_NumChannels “64”
SET maxFPS “0”
SET Sound_EnableHardware “1”
SET readContest “-1”
SET componentTextureLevel “0”
SET processAffinityMask “255”
SET checkAddonVersion “0”
SET Sound_EnableErrorSpeech “0”
SET realmName “Thrall”
SET gxFixLag “1”
SET shadowTextureSize “2048”
SET maxFPSBk “8”
SET environmentDetail “150”
SET Sound_EnableMusic “0”
SET weatherDensity “3”
SET gxMonitor “1”
SET gxResolution “1920x1200”
SET gxMultisample “4”
SET waterDetail “3”
SET shadowMode “2”
SET gxVSync “1”
SET lastCharacterIndex “1”

I am just trying with a GTX 570 instead of a GTX 460, and it doesn’t seem to crash (yet), using the same wine version, patches and settings.

Just tried again with a GTX 570. The crashes with 313.26 still do happen, but it seems less frequently. I was doing a 5 man hero instance followed by a solo scenario and it crashed after leaving the scenario. So I am having this kind of crashes:

313.09: Generally stable, even after hours of play.

313.26: GTX 460 in directx9 mode, all effects: crashing very fast.
GTX 460 in opengl mode, less effects: crashing typically after leaving an instance (some minutes)

    GTX 570 in directx9 mode, all effects: crashing typically after leaving an instance (some minutes)
    GTX 570 in opengl: no tried.

Temperatures are about 55°, this seems to not a problem.

I am not able to reproduce this issue with Ubuntu 13.04 32-bit + X.Org X Server 1.13.3 + GF104 [GeForce GTX 460] + 313.26 driver + WoW Mists of Pandaria with settings provided by hirschhornsalz.

I am using a 64 bit installation. Both the 32 bit wow.exe and the wow-64.exe keep crashing as soon as I install 313.26.

Im also using 64bit Ubuntu 13.04 here…
Have you tried Starcraft 2 also ?