glvnd + Nvidia = Crash at many games

Hi there,

I just set up a glvnd setup at my linux machines, but I’m experiencing crashes at some games using nvidia glvnd flags. Few of them are:

  • Hearts of Iron IV (Steam)
  • Europa Universallis IV (Steam)
  • Stellaris (GOG)
  • Kingdom Come: Deliverance (Steam Proton)
  • No Man Sky (Steam Proton)

All of those games run correctly if I unset __GLX_VENDOR_LIBRARY_NAME env variable, but very slow (Intel integrated will work)

Now, I tested many other games with the glvnd flags and works correctly, like:

  • Cities Skylines (Steam)
  • BioShock Infinite (Steam)
  • Don’t Starve (GOG/Steam)
  • ARK (Steam)
  • AoE 2 (Steam Proton)
  • Grid Autosports
  • DiRT 4
  • F1 2017
  • Mad Max

So, my question is, is this happening due specific issues or I’m doing something wrong?

My command to run games would include:


Also as extra data:



I faced the same problem.

I solved this issue by downgrade libgvnd with command :

“sudo downgrade lib32-libglvnd libglvnd” (choose version 1.1.1)

I also ran into this issue and tracked it down to fsaa multisampling. Enabling multisampling with nvidia-driver 440.44 causes crashes, disabling it fixes them.

Changing versions of libglvnd did not help.

I can confirm both quotes. I tried downgrading libglvnd version and didn’t work for me neither, also disabling FSAA multisampling for EU4, HoI4 and Stellaris works as expected.

Not sure if a driver or Paradox Engine issue, but as those games correctly with PRIME, it makes me think is driver issue.

Many thanks for the workaround nvidiadwbta.