gnome don't start when option composite is disabled and stereo 3D vision pro

I use Fedora 25 or centos 7 with quadro M6000 and NVIDIA driver 375.20
All works fine when composite is not disable.
But to use the stereo with some programs like VMD it’s necessary to disable composite in the xorg.conf
Section “Extensions”
Option “Composite” “Disable”
EndSection

When this option is added, gnome don’t start

Any body have a solution ?

Thanks in advance

Gnome shell won’t work without composition. Use Gnome Flashback or any other WM.

Many thanks Generix,

if I use KDE with Centos 7, Option “Composite” “Disable” works.
To use Gnome shell, I have replaced Centos 7 by Centos 6.8, and all work fine.