gnome + wayland + nvidia question

I can only get gnome + wayland + nvidia to start in software rendering mode. I don’t think it is isolated to my fedora install as Arch seems to have the same problem, https://bugs.archlinux.org/task/53284 .

Does anyone know where the problem lies? Thanks.

#1 Without "nvidia-drm.modeset=1" , gnome falls back to X11
gnome-shell[1261]: Can't initialize KMS backend: could not find drm kms device
gnome-session[1254]: gnome-session-binary[1254]: WARNING: App 'org.gnome.Shell.desktop' exited with code 1
#2 With "nvidia-drm.modeset=1" , gnome wayland starts but is very slow
gnome-shell[1634]: Failed to apply DRM plane transform 0: Invalid argument
org.gnome.Shell.desktop[1634]: Disabling glamor and dri3, EGL setup failed
org.gnome.Shell.desktop[1634]: Failed to initialize glamor, falling back to sw

Someone answered my question in
https://bugzilla.gnome.org/show_bug.cgi?id=773629

Fedora hasn’t enabled --enable-egl-device in mutter including rawhide and f26

http://pkgs.fedoraproject.org/cgit/rpms/mutter.git/tree/mutter.spec#n117