Got CUDA running on Fedora Core 7 Beta 4.

Not that complex but it took some time. I install the beta 4 with the LiveCD, but need to install gcc, kernel devel, libXi, etc.
Notes:

  1. Logging into X with default driver, install packages: gcc, kernel devel, libXi,… (cannot remember exactly). Of source download the 9751 driver.

  2. Then Ctrl+Alt+F1 to log in as root, run “telinit 3” to kill X. Install driver with:
    “sh NVIDIA-Linux-x86-1.0-9751-pkg1.run --x-module-path=X -showDefaultModulePath 2>&1 | cut -d, -f1 --x-library-path=X -showDefaultLibPath 2>&1”, otherwise the X cannot find the driver.

  3. After upgrading to new kernel, the old kernel interface may not work. Then when you try to re-install, it will fail because whatever i386/Makefile cannot be found. To work-around this, “export ARCH=i386” before you re-install the driver.

  4. “startx” to launch X. “Applications->System Tools->NVIDIA X Server Settings”, you should see the GPU info.

  5. Now try to get OpenGL going with GLUT. Need to confirm that you can compile and run some glut demos. May hit various problems but should not be hard to solve. I compiled mjk’s 3.7.13 glut. You may also need to find a glu.h from somewhere. I will omit 1000 words here. If any question, post.

  6. Install CUDA Toolkit and SDK.

  7. Before compiling the SDK, you may want to do this first:
    “export LD_LIBRARY_PATH=/usr/local/cuda/lib:$LD_LIBRARY_PATH”

  8. Make.
    You may hit an error that Xmu needed, in the common/common.mk, add -lXmu. If not seeing this, you are lucky.

  9. No matter compiling or run the tests, there may be a problem some library is not permitted to be loaded, then run chcon to grant the permission, for example:
    “chcon -t textrel_shlib_t /usr/local/cuda/lib/libfatZip.so”, you can run this to all libs if you want simple.
    (Do this to libcufft.so.0.8 before run fluidsGL.)

  10. When run tests, the “data” folder is needed for some tests, grab them from the projects to the release bin folder.

After you pass all the tests, done!

APPENDIX

The first test to run? bandwidthTest!!!
The three numbers you get may be: ~1200, ~1000, ~8500. (MB/sec).
If your number is something like 240GB/sec. Congratulations! You might install 9755 driver. :wave: 9751 is required.

:ph34r:

Thanks for the how to it worked perfectly on Fedora 7 final.

FC7 32 bit works right away !! only that I had to face the awesome 250GBps :P … had to revert from 9755 to 9751 …

thanks for a well written post…

Just one more tip you may want to add. Doing

export LD_LIBRARY_PATH=/usr/local/cuda/lib:$LD_LIBRARY_PATH

At the prompt will only work for that session if you want it to work for every session add that to /etc/profile (at the end) Also note that that will only work if you installed into a system dir and not your home directory.

Also if you want to install it into /opt or some other path you will also need to add

PATH=$PATH:/opt/cuda/bin

To /etc/profile and change /usr/local/cuda/lib to /opt/cuda/lib

Thanks for the great install guide, works perfectly on Fedora 6 as well :yes:

As an alternative to 5) you can use freeglut (install fedora packages “freeglut” and “freeglut-devel”) and fix a bug in the SDK that other glut implementations don’t catch:
In NVIDIA_CUDA_SDK/projects/boxFilter/boxFilter.cu and fluidsGL.cu accordingly add glutInit(&argc, argv) after glutInitWindowSize.

Has anyone else tried CUDA 0.9 with driver 100.14.10 on Fedora ?
I tried, already the frst test “alignedTypes” fails and the last figure in the bandwidth test is off 47GB/sec … :no: