GPIO permission issue

Good afternoon everyone, reopening this question as no answer was provided on my previous post.

When trying to control a stepper motor through the GPIO header on the AGX Xavier I ran into the following issue:

When utilizing the jetson-gpio library for python compatible GPIO control I am able to run all sample scripts (including the ‘’, this is relevant later in this post).

However, when I attempt to use the JetsonGPIO librari for c++ compatible GPIO control the following error appears when using the GPIO::PWM() command (with sudo):

Without sudo i get this exception:

Screenshot from 2020-10-14 12-14-25

The same command in Python (syntax) does work however. I have moved the 99-gpio.rules file to /etc/udev/rules.d and created the gpio group and added my user to this group. I have tried running all commands with sudo, with no effect unfortunately.

My output with this command is provided below

$ sudo cat /sys/kernel/debug/pwm

Does anyone know how to solve the permission issue? I would really like to use the GPIO::PWM function in a C++ script rather than python.

Best regards,


Hi Ruud,
Jetson GPIO library is py compatible.
Let me know your usecase with PWM so that I can help you out in some other way.