GPIOs not suddenly not working anymore

Hi,

i am working on a project on the Nvidia Jetson Orin Nano Dev Kit and suddenly the GPIOs stopped working. I created a C Program that used libgpiod to toggle the GPIOs embedded in the CSI Connector and everything worked fine. Then I wanted to change the GPIO and use Pin 7 of the 40 Pin Header. When probing the pin, i saw no changes. Then I tried Pin 12 and this also did not worked. Then I switched back to the first GPIO that i was using successfully, only to notice that its now also not working.

I also tried to use Jetson.GPIO in Python to see if i could get the GPIOs to toggle from there but this also wasnt working.

When I start my Program and use the gpioinfo command, i can see that the correct GPIO is being used by my program.

Thats why I think it isnt a software problem. I am not 100% sure, but maybe when I was probing the 40 Pin Header i shorted some pins on accident with my probe. I am also not 100% sure if i smelled something burned, but i could be the case. Apart from the GPIOs, everything on the Jetson works fine.

Could someone maybe point me in a direction, how i could solve this problem or maybe tell me, which parts/ics/… i could have accidently destroyed by probing

Best regards,
Tim

Hi,

What L4T/JetPack version are you using?
If you have JetPack 5, use sysfs to check whether you can control the pin correctly.
If you have JetPack 6, first go back to JetPack 5 and do what I said above.

If they still don’t work, then it does look like hardware failure, and please RMA the device.