GPS connection on Jetson TX2 Board?

Hello, I’m trying to connect EVK-M8L GPS module on Jetson TX2 Board.
(We will try C94-M8P as well)

Baudrate of the GPS module is set to be 9600 and I tried 3 things as below

  1. Connection of RS232 to USB cable to USB connector
    This worked well, but we want to connect the GPS module through serial port
    since we wanna deal with the the situation that USB hub is disconnected somehow.
    In addition, we might use the RS232 port for sending RTCM message to the GPS module.

  2. J21 Expansion Header
    I used J21 pin 10 for reading GPS data from EVK-M8L and pin 9 for GND.
    (EVK-M8L TX to J21 pin10, EVK-M8L GND to J21 pin 9)
    It seems that buffer overrun happens at 9600 baud rate. Data from GPS module comes only once and
    not anymore(maybe buffer overrun…?). I tested 115200 baud rate and it seems work properly.
    I’m wondering why buffer overrun happens at 9600 baud rate. Can I use this module at 9600 baud rate?

  3. J17 Serial Port Header
    It was blocked at the first time. After flashing it, I found this port is open.
    (I was supposed to patch: https://devtalk.nvidia.com/default/topic/1001264/jetson-tx2/tx2-uarts/post/5125115/#5125115)
    So, I tried to use this port(EVK-M8L TX to J17 pin4, EVK-M8L GND to J17 pin 1) at 115200 baud rate.
    It seemed to work well for some minutes, but after rebooting, I found the root password has been changed and I couldn’t get into ubuntu. After force rebooting, only bluescreen popped up since then.
    (I’m reflashing TX2 again;;)

What should I do to connect EVK-M8L GPS module(C94-M8P as well) to TX2 board stably?

Thanks!

By the way, the reason why I chose 115200 baud rate is that the baud rate is automatically changed to be 115200 even if I set it as 9600 first. Only the first data comes well at 9600 and then the buad rate seems to be set as default(115200). My hypothesis is that if the default baud rate is set to be the same value of the GPS module baud rate, there will be no errors.

hello taedong89,

there’s documentation for your reference.
[Release 28.1 Development Guide]-> [PDF Documents]-> [Tegra Linux Driver Package TX2 Adaptation Guide]

Hey JerryChang,

I’m having a very similar issue but I couldn’t find the file you’ve referenced. Would it be possible to provide a link to the file? Or the start of the file path?

Thanks
Doug

hello dougoxc1a,

please check them in the Jetson Download Center,
thanks

https://developer.nvidia.com/embedded/downloads

Hello,

I am currently trying to connect Adafruit Breakout GPS module to Jetson Via J21 header. I have powered the GPS through pin 2 , connected ground to pin 9 , and connected GPS TX to pin 10 J21 , GPS RX to pin 8 J21.

How can i read the data coming from the gps? Can I do it through terminal commands? If not, is there any documentation to help guide me through reading GPS data from Pin 9 J21?

hello marwansallam97,

please check NVIDIA Jetson TX2 J21 Header Pinout, you should setup serial console to access UART#0.
thanks