GPS example cannot consume fast enough

Please provide the following info (check/uncheck the boxes after clicking “+ Create Topic”):
Software Version
DRIVE OS Linux 5.2.0
DRIVE OS Linux 5.2.0 and DriveWorks 3.5
NVIDIA DRIVE™ Software 10.0 (Linux)
NVIDIA DRIVE™ Software 9.0 (Linux)
other DRIVE OS version
other

Target Operating System
Linux
QNX
other

Hardware Platform
NVIDIA DRIVE™ AGX Xavier DevKit (E3550)
NVIDIA DRIVE™ AGX Pegasus DevKit (E3550)
other

SDK Manager Version
1.6.0.8170
1.5.1.7815
1.5.0.7774
other

Host Machine Version
native Ubuntu 18.04
other

I tried out the gps sensor example on the Xavier drive kit. The program seems to detect the GPS, but only outputs “GPS: message decoder cannot consume fast enough, dropping bytes.” I can read the GPS using the Python serial library so the parameters shouldn’t be the issue. How should I go about solving this issue, do I need to up the baud rate on the device?

Dear @lucas.vandijck,
Could you share complete log? Do you see any improvement if baud rate changes?

It seems now I can’t even run the script anymore because libcublas.so.10 is missing.

Dear @lucas.vandijck,
Could you update the LD_LIBRARY_PATH to have libcublas.so?

Where would this be located?

Hi @lucas.vandijck , It should be in /usr/lib/aarch64-linux-gnu/ .

1 Like

Changing the baud rate to 115200 worked.

1 Like

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.