GPU computing SDK setup problem

Hi,

I tried to install the GPU computing SDK 4.0.17.

Installshield is launched (with message “Starting InstallShield Wizard”), but shortly after that I get the message “Setup.exe stopped working” and setup is aborted. I tried both 32 & 64 bit SDK versions on 2 different PCs, both have Windows7 SP1 64bit installed. I redownloaded the SDK several times, with same result.
I successfully installed however the same downloaded exe on an old PC with Windows XP making sure that the downloaded file is not corrupted.

After a failed setup, I find the extracted installation files in my user folder …\AppData\Local\Temp…\Disk1. I tried to run setup.exe directly from there, but with the same error.

Has anyone a solution or explanation?

Thanks

Try not using a downloader to download the SDK and use Internet Explorer… Also, you may restart your system and see if it helps…

I used IE9 for the download, anyway the downloaded file is not corrupt as it installs on a Windows XP PC.

Rebooting system does not work either.
Is there any other way to install the GPU Computing SDK?

The installation of the CUDA toolkit and Parallel Insight did not cause any problems.

Can’t I just copy the installed files from the Windows XP installation? or does the installation also sets environment vars or changes the registry?