GPU fans not spinning on ARCH Linux

Hello. I recently installed ARCH Linux because I wished for a more accessible computing environment. But, after two days of usage, I have just now noticed something - my GPU fans aren’t spinning. I’m certain I installed all the drivers needed my GPU to run right when I used pacman, all games have been running smoothly and the resolution is right, it’s just the fans. They would spin when I used Windows 10 a few days ago. Did I forget something?
OS - ARCH Linux w/ Cinnamon Desktop Environment
GPU - RTX 2080 Super
CPU - AMD Ryzen 3900x
RAM - 32 Gigabytes

Unless you configured the driver for manual fan control and set the speed to 0, there’s nothing to be configured. The fans are controlled by vbios.
Please put some load on the gpu and run as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

Hello! I did just check, and you’d be right! It’s set for zero spins. But how do I change this? I can’t seem to find a manual mode button anywhere. I appreciate your assistance!

At 35°C the fans are simply off.
Run some unigine demo, see how temperature rises and the fans will start spinning.

NB: setting fan speed to 0 was merely a joke, manual control has a minimum setting of 30% for obvious safety reasons.

But how would I set my GPU to manual mode? I would like the fans running full blast at all times. It gets deathly hot here in the summer, I wouldn’t want to waste my GPU.

You didn’t . Please run some unigine demo, watch temperature in nvidia-settings and the fans should start spinning once the temperature reaches a certain threshold. Might be something between 45-65°C.

I just ran the test. My GPU got all the way up to 68C, and still no fan movement. I really think it would come in handy knowing how to setup manual mode. I need maximum performance for my computer, I’ll be doing loads of rendering on my PC.

Ok, that’s severe. Rather sounds like a hardware issue. You can try setting manual mode to test if the fans are working at all.
To enable manual mode, use the CoolBits option in xorg.conf:
Then set the speed using nvidia-settings
If the fans still don’t spin, RMA the card.

Hmm, I set all fans to 100% speed, but in this screen shot it says only one of them is spinning. But, when my computer starts up, all fans are going full blast. It’s only when ARCH Linux loads.

Could it be something in my MSI motherboard?

The mainboard does not have any control over the gpu’s fans. The graphic’s card vbios is responsible for it. What’s the exact model? Does it have switcheable bioses?

The GPU I’m using is the MSI GeForce 2080 Super Gaming X Trio. I don’t know what a switchable BIOS is, sorry.

Some graphics card have two video bioses on-board with different fan-curves/clockings, aka quiet/performance bios. Yours doesn’t have that.
Looks like this model has a custom fan design, so the values from nvidia-smi might not be correct. There’s little info about it but it seem fans start only spinning way over 60°C. Other that that, I can’t really help you, don’t know what’s happening.

Purge, and reinstall the driver.