GPU not able to load driver

Hi there, every time I looked through the internet for some answers I kept ending up scrolling through this forum so I thought I might ask for help here.

I have an MSI GS65 Stealth laptop with a GTX1060 mobile graphics card. When I was using windows everything worked for a few years but while the laptop sat idle for a few months with a broken monitor the GPU decided that once the screen was fixed it wasn’t going to work anymore.

Some helpful people on the ubuntu forum ran me through some steps to try and get the driver to work including disabling secure boot but at the end of that I was still getting

‘’’ sudo ubuntu-drivers autoinstall
[sudo] password for jack:
WARNING:root:_pkg_get_support nvidia-driver-390: package has invalid Support Legacyheader, cannot determine support level
Reading package lists… Done
Building dependency tree
Reading state information… Done
The following packages were automatically installed and are no longer required:
lib32gcc-s1 libc6-i386 libllvm11
Use ‘sudo apt autoremove’ to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade’’’

Attached is the bug report. Any guidance is very much appreciated, hoping the GPU isn’t cooked.

p.s. sorry I dont know how to use the code boxes on this forum
nvidia-bug-report.log (2.0 MB)

Hello, to format code, just use three back ticks, like «`», or you may select and click on icon with tooltip «Preformatted text», or use Ctrl-E…