GPU not showing up

I’m still kind of new to Ubuntu(only been using it for a couple months) and just noticed today that my graphics card isn’t being used when I play a game. I’ve done some Google research and tried some commands that I was told would show both my Intel and my NVIDIA card. When I used the command only the Intel one showed. I updated to the latest driver.

One error that sticks out to me is when I run the command “nvidia-settings”, the GUI opens up but back on the terminal I get:

GPU at BusId 0x1 doesn’t have a supported video decoder
** Message: 14:28:11.984: PRIME: Requires offloading
** Message: 14:28:11.984: PRIME: is it supported? yes

ERROR: Unable to open file ‘/home/tyler/.nvidia-settings-rc’ for writing.

I’m not really sure what I’m supposed to do to get it to work. I apologize if this has been answered somewhere and please let me know if I need to fix wording or provide any more info.

Please run as root and attach the resulting nvidia-bug-report.log.gz file to your post. You will have to rename the file ending to something else since the forum software doesn’t accept .gz files (nifty!).

Ok I have the .gz file but i’m not sure what to change it to to make it upload. Or does it not matter because you can probably change it back to .gz and you can read it?

Just put a .txt at the end, I’ll remove it then. Or unzip it and attach the .log if it’s not too large.

nvidia-bug-report.log (1.2 MB)

According to the logs, everything is fine, the driver is loaded, everything runs on the nvidia now. The warning messages when running nvidia-settings can be ignored, those always show up.
Or are there any issues?
You might want to set the kernel parameter
for a tearfree display.
Keep in mind that you only have a 920MX, that’s not very powerful.

Granted it’s not a powerful card, I haven’t really had issues when this laptop was on windows. I could play games with not-so-demanding graphics and run perfectly fine.

Fps seemed like a bit of an issue with borderlands 2 at low settings. I had to turn more settings down and then that’s when I decided to see about updating the drivers and even making sure the game was using the card. That’s how I found out that only my Intel Graphics showed up on the list of active cards even when I was running a game while I entered the command. I think that’s the part that makes me feel like my Nvidia card is not being used when I run a game.

You can check which OpenGL implementation is active by issuing
glxinfo |grep vendor

With dxvk, now sometimes running the Windows version is faster than an older Linux port using OpenGL.

Using that command it just told me

OpenGL vendor string: NVIDIA Corporation

Not sure if this is really an answer.