GPU not showing using lspci in a UEFI Mint

Hi all,
I have installed UEFI linux mint system with tesla v100 sxm2 GPU.
After installation of the OS in UEFI. I am not able to see GPUs using lspci.
Even if i run command update-pciids. It is not able to show the devices.

I have seen some Legacy/EFI option for the PCIe devices in the boot menu. I checked in both mode, but nothing helped.

I want to understand what is happening and how to resolve it.
Any help is apreciated.

Thanks.

SXM2 is not PCIe, so I guess that’s the reason why it’s not shown in lspci.

So how should i see the devices(GPUs).

and earlier it was showing when i had legacy Mint

Yes, you’re right. They also have a pcie part so they should show up with lspci. What’s the output in your case?

I am not sure it is connected to pci or in SXM2 but my motherboard(SuperMicro) has sxm2 slot and in previous installation of mint it use to show lspci and the GPUs were also connected to eachother using nvlink.
The output is all the devices except for the GPUs

Please run nvidia-bug-report.sh as root and attach the resulting .gz file to your post. Hovering the mouse over an existing post of yours will reveal a paperclip icon.
https://devtalk.nvidia.com/default/topic/1043347/announcements/attaching-files-to-forum-topics-posts/

Hi i was installing mint 18.3 so i changed os
i used ubuntu 18.04.5 and it worked.
But due to some other reasons i have to reinstall the same ubuntu and again it is the same issue.
Not it is able to detect devices in lspci.
Can you help without the bug-reports

Sounds like you need a newer kernel, which kernel version are you running now that doesn’t work?

4.15.0-45-generic

Try upgrading the HWE stack, should give you kernel 4.18:
https://wiki.ubuntu.com/Kernel/LTSEnablementStack

Sorry i was using ubuntu 16.04.5 although i am trying to follow the steps in the link mentioned, thanks for the helping me out

I tried its not working

i updated and now the kernel is 4.15.0-46-generic

Are at least the underlying bridges visible and attched to the right pcieport driver?
sudo lspci -k -d 10b5:*
Does installing the additional driver package linux-image-extra help?

sudo lspci -k -d 10b5:*
shows nothing
i am trying to install the mentioned package

linux-image-extra was not able to locate one of the stackflow ans said its renamed to linux-modules-extra so i tried that and that says already present so nothing happen.

I have seen the supported kernel for ubuntu 16.04 is 4.4 any suggestions

Which cpu model is installed?

x86_64

I meant the output of
cat /proc/cpuinfo |grep “model name”