GPU performance mode higher than expected

I am running Arch with KDE, and I have 3 monitors with 4k@60hz + 2k@60hz + 1080p@60hz, nvidia-smi told me that

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 515.43.04    Driver Version: 515.43.04    CUDA Version: 11.7     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
| 35%   53C    P0    92W / 350W |   1208MiB / 12288MiB |     12%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A       614      G   /usr/lib/Xorg                     493MiB |
|    0   N/A  N/A       762      G   /usr/bin/kwin_x11                 168MiB |
|    0   N/A  N/A       815      G   /usr/bin/plasmashell              157MiB |
|    0   N/A  N/A      1136      G   ...akonadi_archivemail_agent        4MiB |
|    0   N/A  N/A      1151      G   .../akonadi_mailfilter_agent       56MiB |
|    0   N/A  N/A      1173      G   ...n/akonadi_sendlater_agent        4MiB |
|    0   N/A  N/A      1176      G   ...nadi_unifiedmailbox_agent        4MiB |
|    0   N/A  N/A      1646      G   /usr/lib/firefox/firefox          196MiB |
+-----------------------------------------------------------------------------+

but on Windows, same machine (another ssd), same monitors, I have

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 512.77       Driver Version: 512.77       CUDA Version: 11.6     |
|-------------------------------+----------------------+----------------------+
| GPU  Name            TCC/WDDM | Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ... WDDM  | 00000000:01:00.0  On |                  N/A |
|  0%   34C    P8    27W / 350W |    857MiB / 12288MiB |      1%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A       892    C+G   ...ekyb3d8bbwe\YourPhone.exe    N/A      |
|    0   N/A  N/A      6644    C+G   ...artMenuExperienceHost.exe    N/A      |
|    0   N/A  N/A      6992    C+G   ...batNotificationClient.exe    N/A      |
|    0   N/A  N/A      8728    C+G   C:\Windows\explorer.exe         N/A      |
|    0   N/A  N/A     10264    C+G   ...n1h2txyewy\SearchHost.exe    N/A      |
|    0   N/A  N/A     10616    C+G   ...ram Files\LGHUB\lghub.exe    N/A      |
|    0   N/A  N/A     11728    C+G   ...y\ShellExperienceHost.exe    N/A      |
|    0   N/A  N/A     12404    C+G   ...cw5n1h2txyewy\LockApp.exe    N/A      |
|    0   N/A  N/A     14568    C+G   ...8bbwe\WindowsTerminal.exe    N/A      |
|    0   N/A  N/A     15328    C+G   ...2txyewy\TextInputHost.exe    N/A      |
|    0   N/A  N/A     15408    C+G   ...perience\NVIDIA Share.exe    N/A      |
|    0   N/A  N/A     17168    C+G   ...bin\jetbrains-toolbox.exe    N/A      |
|    0   N/A  N/A     17184    C+G   ...zilla Firefox\firefox.exe    N/A      |
|    0   N/A  N/A     20216    C+G   ...210.47\msedgewebview2.exe    N/A      |
|    0   N/A  N/A     22116    C+G   ...obeNotificationClient.exe    N/A      |
+-----------------------------------------------------------------------------+

the performance level and power used is significantly different. And, on Arch, if I change that 1080p@60hz to 50hz, nvidia-smi outputs like this:

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 515.43.04    Driver Version: 515.43.04    CUDA Version: 11.7     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|                               |                      |               MIG M. |
|===============================+======================+======================|
|   0  NVIDIA GeForce ...  Off  | 00000000:01:00.0  On |                  N/A |
| 35%   47C    P3    64W / 350W |   1180MiB / 12288MiB |      7%      Default |
|                               |                      |                  N/A |
+-------------------------------+----------------------+----------------------+
                                                                               
+-----------------------------------------------------------------------------+
| Processes:                                                                  |
|  GPU   GI   CI        PID   Type   Process name                  GPU Memory |
|        ID   ID                                                   Usage      |
|=============================================================================|
|    0   N/A  N/A       618      G   /usr/lib/Xorg                     538MiB |
|    0   N/A  N/A       768      G   /usr/bin/kwin_x11                 178MiB |
|    0   N/A  N/A       848      G   /usr/bin/plasmashell              154MiB |
|    0   N/A  N/A      1104      G   ...akonadi_archivemail_agent        4MiB |
|    0   N/A  N/A      1123      G   .../akonadi_mailfilter_agent        4MiB |
|    0   N/A  N/A      1128      G   ...n/akonadi_sendlater_agent        4MiB |
|    0   N/A  N/A      1129      G   ...nadi_unifiedmailbox_agent        4MiB |
|    0   N/A  N/A      1567      G   /usr/lib/firefox/firefox          231MiB |
+-----------------------------------------------------------------------------+

drop 1080p 10hz will decrease power by 30W and from P0 to P3…

I am expecting it should be like on Windows (at least not as significantly different like this), should be around 30W and P8. Any reasons for this and any solutions ?