GPU virtualization Openstack A100

I have the following issue:
I have one server DELL with A100 Nvidia. On the server Dell I can observe that nvidia-smi is working. Everything fine till now.
When I create an ubuntu virtual machine on this server Dell and I run: lshw -C display:
I get the following output:

**-display:0 UNCLAIMED *

  •   description: VGA compatible controller*
  •   product: QXL paravirtual graphic card*
  •   vendor: Red Hat, Inc.*
  •   physical id: 2*
  •   bus info: pci@0000:00:02.0*
  •   version: 04*
  •   width: 32 bits*
  •   clock: 33MHz*
  •   capabilities: vga_controller*
  •   configuration: latency=0*
  •   resources: memory:f4000000-f7ffffff memory:f8000000-fbffffff memory:fc0d0000-fc0d1fff ioport:c100(size=32) memory:c0000-dffff*
  • -display:1
  •   description: 3D controller*
  •   product: NVIDIA Corporation*
  •   vendor: NVIDIA Corporation*
  •   physical id: 6*
  •   bus info: pci@0000:00:06.0*
  •   version: a1*
  •   width: 64 bits*
  •   clock: 33MHz*
  •   capabilities: msix bus_master cap_list*
  •   configuration: driver=nvidia latency=0*
  •   resources: iomemory:70-6f iomemory:60-5f irq:11 memory:fc080000-fc0bffff memory:700000000-7ffffffff memory:640000000-641ffffff*

After this I installed the Nvidia-driver and I run nvidia-smi. Now on the virtual machine, I have the following output: “No devices were found”.
If you have any ideea, let me know.
My log file is this:
nvidia-bug-report.log.gz (77.5 KB)