Grab image by Libargus but image is replicated

I recently grab image from 8 cameras using virtual channel, the image is different and normal by v4l2 applications, but when I used libargus to grab image, the image from camera#0 is the same as camera#4, the image from camera#1 is the same as camera#5, the image from camera#2 is the same as camera#6, the image from camera#3 is the same as camera#7, does libargus support grab image from 8 cameras simultaneously by virtual channel? Is there some config in libargus to support 8 cameras to work simultaneously?

hello buaa_hebiao,

this is known issue, here’s pre-built library based-on l4t-r32.1 to include the fix, please replace with the attachment for verification.
also, we had include the fix for the next public release. (i.e. JetPack-4.2.1 / l4t-r32.2)

devtalk1056808_Jul08.tar.gz (789 KB)

Hi jerryChang,
Thanks for your reply, I had tried to replace in /usr/lib/aarch64-linux-gnu/tegra/, but it still not work, is there any other config I have to apply on the issue?

hello buaa_hebiao,

may I know had you tried to perform warm-reboot to have change takes effect?

$ sudo reboot

Hi JerryChang,
Thanks for your patient reply, I forgot to reboot to load the .so, now it works well through libargus to grab image from 8 cameras.