Graph Composer Version Compatibility Question

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU) NVIDIA GeForce RTX 2080 Ti
• DeepStream Version 6.0.1
**• JetPack Version (valid for Jetson only)**N/A
• TensorRT Version 8.0.1
• NVIDIA GPU Driver Version (valid for GPU only) 470.57.02
• OS Ubuntu 18.04
• Issue Type( questions, new requirements, bugs) Question
I need to use Graph Composer to compose a graph on this (dGPU) machine that will be executed on a Jetson Xavier NX. The Jetson Xavier NX is running Jetpack 4.6.1 and has Deepstream 6.0.1 installed. To install Graph Composer with Deepstream 6.0.1 the Quickstart guide, under the Graph Composer Installation section, specifies that graph composer 1.0.0 should be downloaded and installed. However, I am unable to find a download for Graph Composer 1.0.0, Only Graph Composer 2.0.0 is available on this page DeepStream Getting Started | NVIDIA Developer . My question is if it is okay to install Graph Composer 2.0.0 on both my dGPU device and the Jetson Xavier NX or if there is a download for an archived version of Graph Composer somewhere? My worry with downloading Graph Composer 2.0.0 is that it specifies running Ubuntu 20.04 and Deepstream 6.1. Will this cause problems or is Graph Composer 2.0.0 backwards compatible with older versions of Deepstream, Jetpack, and Ubuntu(specifically 18.04)?

To get DS 6.0.1 and Graph Composer 1.0.0, please refer to NVIDIA DeepStream SDK on Tesla (Archived) | NVIDIA Developer

The graph Composer 2.0.0 is for DeepStream 6.1 only. You can not use Graph Composer 2.0.0 with DeepStream 6.0.1.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.