Graphic issue with Bentley Stadd and VGPU

We are running XD 7.6 on XS 6.5 using the 340.78 vgpu driver on a new dell r730. We have discovered when opening up models using Bentley STADD SS5, it won’t display the entire model and every time I hit refresh, only parts of the model show up. We have tried using the vgpu version 337.59 for Xenserver 6.2 with the same results.
What is odd is the issue does not occur if we RDP into the VM or using Lync Screen sharing. I guess this is because it is using the remoting protocol and not the graphic driver. Even if I take a screenshot using the snipping tool or print screen the entire model shows up correct. When I use the Xenserver console there are no issues. We have also tried creating a profile for the program in the Nvidia control panel and changed some settings with the same results.
We reached out to Bentley and are waiting for a response.
To better explain the issue, I posted two videos of what it is doing and how it is supposed to look.

Video of the issue: https://youtu.be/c28ug7fLFLk

Video of it working: https://youtu.be/cxKyVitb2RE

Doesn’t look great…

Have you logged this with Citrix or asked about it in their forums?

Can you confirm that the montereyenable.exe functionality is enabled to ensure NvFBC is in use.

I’d like to se it recreated with another protocol that uses NvFBC ( Nice DCV or Mechdyne Telegraphix if you’re using XenServer. ) just to pin down whether or not it’s the protocol.

Thanks for the quick response and sorry for my late response. I finally got around to testing your suggestion and when i disable NvFBC using the montereyenable.exe utility, it works! Now do you suggest that i contact citrix support or is this a nvidia driver issue.

Monterey Enable allows the VDA to read directly from the framebuffer. So start with Citrix if it’s only afecting their protocol.

I also forgot to ask what vGPU profile you’re using.

Thanks i opened a ticket with Citirx. We tried k120q through k180q and pass through.

When you switched between vGPU and passthrough, did you change to the passthrough drivers?

the latest vgpu drivers from Nvidia fixed the issue thanks