Graphical corruption in Gnome Shell when resuming from sleep on Nvidia 495.44

After upgrading to Nvidia 495.44 on my Arch Linux install, I am experiencing weird graphical glitches in Gnome Shell whenever I resume from sleep. It doesn’t appear every single resume, but it appears quite frequently enough to be bothersome. I can attach a screenshot the next time I encounter this issue.

I do have NVreg_PreserveVideoMemoryAllocations=1 turned on since I need it for Blender to work properly after resuming from sleep. If I turn it off, the corruption issue seems to not occur, at least as far as my personal testing goes, but then of course Blender totally breaks until I restart the program.

Currently, my workaround is to just hit Alt-F2 and type r into the run box to restart Gnome Shell, but having to do this every time is quite annoying.

Is this bug known and can we get it fixed?

Here are the nvidia logs:
nvidia-bug-report.log.gz (924.8 KB)

EDIT: Attached screenshots

1 Like

Please try setting NVreg_TemporaryFilePath to e.g. /var/tmp

What does this do? Is it supposed to fix the issue or is this just for logs?

It sets the directory where parts of the video memory are dumped to. Default is /tmp which is often tmpfs.

I did some testing with the following modprobe options:

options nvidia_drm modeset=1
options nvidia NVreg_PreserveVideoMemoryAllocations=1
options nvidia NVreg_TemporaryFilePath=/var/tmp
blacklist nouveau

However, I just ran into the same issue so I don’t think changing the temp folder location is working.

I’ve seen something similar with Wayland (which is probably not unexpected), resuming under Xorg might be improved with upgpkg: xorg-server 21.1.2-2: fix FS#73075 · archlinux/svntogit-packages@56fe610 · GitHub

I’ve already tried it with this fix. Graphical issues still exist after resume, but at least it properly resumes now instead of giving me a black screen like 21.1.2-1 did.

1 Like

Thinking a bit more, this seems to trigger a memory… I can’t remember exactly where I saw this, but I think I saw a similar issue and it was related to an extension or system or shell theme (e.g. try Adwaita if you aren’t already using it).

I’m also experiencing graphics corruption (random squares) in applications after resuming from sleep. I use Gnome Xorg session (Wayland is broken for Optimus laptops) on Arch Linux.

Due to forum limitations I can only upload an image per post

@user191239281 I am already using Adwaita. As for shell extensions, I am using:

  1. Sound Input & Output Device Chooser
  2. Tiling Assistant
  3. Tray Icons: Reloaded

Any of these ring a bell?

@victorsbayas I am getting the exact same graphical issues you are in addition to the graphical glitches in Gnome Shell.


I started experiencing this same problem several weeks ago with the 495.46 nvidia driver.
Yesterday, I installed some updates which included a new kernel (5.16.7-100) and a new version of the nvidia driver (510.47), and I’m still seeing the same corrupted graphics problem after a resume.

Anyone have any info on when a fix might be available? Is this a known problem that has been reported “properly”?


1 Like

As per what generix suggested, I was having this issue on Fedora 35 with Gnome and XWin (rather than Wayland - because of the nvidia driver) and creating an /etc/modprobe.d/nvidia.conf and putting this line in it seems to have resolved it for me:
options nvidia NVreg_TemporaryFilePath=/var/tmp

Does having the correct (ACPI) kernel parameters set for your specific hardware platform help?
Example Only:
" acpi_osi=! acpi_osi=‘Windows 2020’ acpi_enforce_resources=lax acpi_sleep=s3_mode mem_sleep_default=deep numa=off iommu.forcedac=1 iommu=memaper "