Graphics debugging: Crash in CreateSwapChain function

Hi, I got Access violation reading location 0x0000000000000000. exception when I use function IDXGIFactory::CreateSwapChain(). It crash in library Nvda.Graphics.Interception.100.dll!000007feda8d2995() when I run graphics debugging, but without NSight, application works. Swap chain isn’t needed for our application (render only into textures with DirectX11), but I can’t run frame debugging (I haven’t enabled Pause and Capture Frame in NSight menu).

Windows 7 64bit, Visual studio 2010 SP1, nsight, nv drivers 310.90

Can anyone help me? Thanks

Have you tried Nsight 3.0 RC2? We have made some significant improvements all around. If you still receive the error, could you show me the lines of code where the SwapChain is created? Or alternatively, send me a binary.

Hi, I tested Nsight 3 RC2 and SwapChain works good now. Our application is also plugin for Autodesk Maya, but when I start Maya with Nsight 3 RC2, it crashed when loading main window (Maya uses OpenGL, so probably crashed in OpenGL init, but with Nsight 2.2 Maya started without problem). When I run our application without Maya, all works, but when I capture a frame “Visual Studio don’t response” window is displayed, but Visual studio still works (but if I click on OK/Cancel button, Visual studio is restarted…), so it works for me now, thanks.