Graphics garbled, even in TTY

So I have the latest version of 32-bit Ubuntu 14.04 LTS installed on a system that has an NVIDIA Quadro FX Series 500/600

On a fresh install of Ubuntu, I get to the login screen fine. But once I enter my password, it goes to a black screen with the mouse visible and useable, and hangs there indefinitely. Booting in low graphics mode via Recovery options allows login fine, although everything renders very slowly.

I tried to uninstall and reinstall nvidia-common and nouveau-video packages. After that, when booting normally, everything renders in a white background with garbled black characters. Even TTY shells are white with all characters garbled. Booting via low graphics mode still works.

Then I booted to just cmd line mode via recovery options, remounted / as read/writeable, and I tried to install the latest nvidia driver for it (173.14.39) and this is how the install went:
“Warning: skipping the run level check (the utility ‘runlevel’ failed to run.)” I hit OK
“The distribution-provuded pre-install script failed!” I hit run anyway
Then during Building Kernel Module phase
“ERROR: Unable to build the NVIDIA kernel module”

Here is the nvidia-installer.log http://pastebin.com/CCX4UdSF

If you need anymore information, let me know.
Thanks for your help.

Update: I found http://www.nvidia.com/object/linux_display_ia32_1.0-9626.html in forums and attempted to install it. This is the error I got during installation

“No precompiled interface was found to match your kernel; would you like to attempt a kernel interface for your kernel from the NVIDIA FTP site?” “yes”

“No match. The install will compile a kernel interface for your kernel.” “ok”

“ERROR: The kernel header file ‘/lib/modules/3.16.0-34-generic/build/include/linux/version.h’ does not exist. Most likely reason is that the kernel source filesin ‘/lib/modules/3.16.0-34-generic/build’ have not been configured”