GROMACS Build Problems

Hi,

I’m trying to build GROMACS (4.0.2) http://www.gromacs.org/.

I’ve been able to build the program using gcc without any problems. However, I’m getting the following error with the PGI compilers:


source=‘nb_kernel_x86_64_sse2.c’ object=‘nb_kernel_x86_64_sse2.lo’ libtool=yes
DEPDIR=.deps depmode=none /bin/sh …/…/…/…/config/depcomp
/bin/sh …/…/…/…/libtool --tag=CC --mode=compile mpicc -DHAVE_CONFIG_H -I. -I…/…/…/…/src -I/usr/include/libxml2 -I…/…/…/…/include -DGMXLIBDIR="/usr/local/summer/gromacs/portland-gromacs-4.0.2/share/top" -O3 -c -o nb_kernel_x86_64_sse2.lo nb_kernel_x86_64_sse2.c
mpicc -DHAVE_CONFIG_H -I. -I…/…/…/…/src -I/usr/include/libxml2 -I…/…/…/…/include -DGMXLIBDIR="/usr/local/summer/gromacs/portland-gromacs-4.0.2/share/top" -O3 -c nb_kernel_x86_64_sse2.c -o nb_kernel_x86_64_sse2.o
In file included from /usr/include/stdlib.h:438,
from nb_kernel_x86_64_sse2.c:85:
/usr/include/sys/types.h:67: error: two or more data types in declaration specifiers
/usr/include/sys/types.h:82: error: two or more data types in declaration specifiers


Here are the command line parameters I’m using:

$ CC=‘pgcc -fast -Mipa=fast -Minline=levels:10’ CFLAGS=’-O3’ CPP=‘pgcc -P -fast -Mipa=fast’ CXXCPP=‘pgCC -P -fast -Mipa=fast --no_exceptions’ CCAS=‘pgcc -fast -Mipa=fast -Minline=levels:10’ F77=‘pgf77 -fast -Mipa=fast -Minline=levels:10’ CXX=‘pgCC -fast -Mipa=fast -Minline=levels:10 --no_exceptions’ CXXFLAGS=’-O3’ ./configure --prefix=/usr/local/summer/gromacs/portland-gromacs-4.0.2 --enable-mpi --enable-fortran --enable-double

$ make install

Any help with this would be appreciated.

Cheers,

Chris

Hi Christopher,

I just downloaded GROMACS 4.0.3 and was able to compile it successfully using the PGI 8.0 compilers. Given that your error occurs with the system header files, it’s more likely a configuration problem.

What OS and what version of the compiler are you using?

  • Mat

I’m using Centos 5.2 with pgcc/pgCC 8.0-1 (64-bit target on x86-64 Linux -tp penryn-64).

Cheers,

Chris

I’ve also tried building Gromacs with the Intel compiler. The Intel compiled version of Gromacs had exactly the same error, and was fixed by adding ‘-Wno-deprecated’ to the C++ compiler flags. (Actually, to avoid clashes with the gnu mpicc, I appended it to the C++ compiler variable, CXX).

Hope this sheds some light on things.

Cheers,

Chris

Hi Chris,

I’m not sure why ‘-Wno-deprecated’ would fix the problem since all it does is disable warning messages.

I’ll ask my IT department to install CentOS 5.2 here locally and see if I can recreate the issue. My best guess is that there is some slight difference with a system header file from our officially supported OSes that is causing the problem.

  • Mat