GST Plugins Bad 1.16.3


i need the gst pluging WPESRC. I know plugin is in the gst plugins bad package.(>=1.16.x)

Ive tried to compile the gst plugins bad but i am getting an error with openexr.

Making install in openexr
make[2]: Entering directory ‘/home/jetson1/gst_1.16.3/gst-plugins-bad-1.16.3/ext/openexr’
CXX libgstopenexr_la-gstopenexrdec.lo
In file included from /usr/include/c++/11/cstdint:35,
from /usr/include/OpenEXR/ImfFrameBuffer.h:55,
from /usr/include/OpenEXR/ImfRgbaFile.h:51,
from gstopenexrdec.cpp:30:
/usr/include/c++/11/bits/c++0x_warning.h:32:2: error: #error This file requires compiler and library support for the ISO C++ 2011 standard. This support must be enabled with the -std=c++11 or -std=gnu++11 compiler options.
32 | #error This file requires compiler and library support
| ^~~~~
make[2]: *** [Makefile:922: libgstopenexr_la-gstopenexrdec.lo] Error 1
make[2]: Leaving directory ‘/home/jetson1/gst_1.16.3/gst-plugins-bad-1.16.3/ext/openexr’
make[1]: *** [Makefile:1042: install-recursive] Error 1
make[1]: Leaving directory ‘/home/jetson1/gst_1.16.3/gst-plugins-bad-1.16.3/ext’
make: *** [Makefile:948: install-recursive] Error 1


I know there is a information about this in git. But i am not able to compile the plugin. Can someone help?

Kind regards

Mats Hensel

Try to add
to your makeffile

Ive modified the line CXXFLAGS and added -std=c++11 but it is not successfull…
CXXFLAGS = -std=c++11

What am I doing wrong?

probably you have to upgrade your compiler

Why do you need to compile the plugin yourself? Not that you shouldn’t be able to but if you just want to use the plugin in an application or CLI pipeline then you don’t need to. You can install them via a package manager if your system has access to one. If you are on a Yocto image without access to a package manager, you should be able to add the Bad Plugins to your build via a recipe.

Good morning, the compiler is up to date. I have installed gcc 11 10 9 and 8.
In the plugins bad packege from the package manager is not the wpe webkit included. That is the reason why need to compile it by my selfe.
I am running ubuntu 20.04.

I really font know how to solve this problem.

Kind regards


You can check the GStreamer source for dependencies.
ext/openexr/ · 1.16 · GStreamer / gst-plugins-bad · GitLab

You could also try a minimal GStreamer build so you don’t waste time building plugins you won’t need.

Generate a minimal GStreamer build, tailored to your needs (

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.