Gst-python installation error

Hi, i recently tried to install the gst-python-1.0 library from this repository After the installation, i encountered a problem where it states that “command Not found”.

Also i tried this method below and encountered this error below:

pip3 install gst-python

Collecting gst-python
  Could not find a version that satisfies the requirement gst-python-1.0 (from versions: )
No matching distribution found for gst-python

what can be the most suitable installation method for the Jetson Nano?

Thanks In advance.

Jetpack 4 release is with gstreamer 1.14.5. Please check if you can download the package and manually build it on Jetson Nano:
Files · 1.14 · GStreamer / gst-python · GitLab

Or see if other users can share experience.

1 Like

I was able to install gst-python for gstreamer 1.14 successfully without errors in jetson nano. But when gst-python command is called, the below error is encountered:

-bash: gst-python: command not found

Found out the executable for gst-python is not created, no errors were encountered during the build.

How to resolve this issue

Thanks in advance.