gst-shark on jetson tx 2

Dear Sir or Madame,

I cannot get gst-shark running on my Jetson TX2. Can anybody help?

I used: and tried it for Ubuntu 64 bits as well as Raspbian/Raspberry Pi option for the ./ script.

However, every time I start a pipeline no traces are being saved. See below. Thanks so much for help,



nvidia@tegra-ubuntu:~/remote-controlled-jtx2-robot/gst-shark$ GST_TRACERS=“scheduletime(filter=videotestsrc0)” GST_DEBUG=GST_TRACER:7 gst-launch-1.0 videotestsrc ! identity name=i0 ! queue ! identity name=i1 ! x264enc ! identity name=i2 ! queue ! fakesink
Setting pipeline to PAUSED …
Pipeline is PREROLLING …
Redistribute latency…
Pipeline is PREROLLED …
Setting pipeline to PLAYING …
New clock: GstSystemClock

You might want to check with its author @ ridgerun. That’s their product and they do provide consulting services.


Hi Thomas

It may be that the tracers are not being installed in the proper location. Can you try the following configuration?

./ --prefix /usr/ --libdir /usr/lib/aarch64-linux-gnu/
sudo make install

If that doesn’t work, please provide the output of the following command:

gst-inspect-1.0 /usr/lib/aarch64-linux-gnu/gstreamer-1.0/

I’ve updated the documentation to include the configuration for the Jetson boards:


Fantastic. It works now. I can see e.g. interlatency results of my gst pipeline. VERY useful.

Thanks Michael and the team at RidgeRun for their great support!