gstreamer command not working

Hi I am trying to display a standard video file. I have a UHD monitor hooked to the X2. I run the following command:

  • gst-launch-1.0 filesrc location=/home/nvidia/ducks_take_off_420_720p50.y4m ! video/x-raw(memory:NVMM), width=(int)1280, height=(int)720, format=(string)I420, framerate=(fraction)50/1 ! nvvidconv flip-method=2 ! video/x-raw(memory:NVMM), format=(string)I420 ! nvoverlaysink -e
    Setting pipeline to PAUSED …
    Inside NvxLiteH264DecoderLowLatencyInitNvxLiteH264DecoderLowLatencyInit set DPB and MjstreamingInside NvxLiteH265DecoderLowLatencyInitNvxLiteH265DecoderLowLatencyInit set DPB and MjstreamingPipeline is PREROLLING …
    NVMAP_IOC_WRITE failed: Interrupted system call
    NVMAP_IOC_WRITE failed: Interrupted system call
    NVMAP_IOC_WRITE failed: Interrupted system call
    Pipeline is PREROLLED …
    Setting pipeline to PLAYING …
    New clock: GstSystemClock
    NVMAP_IOC_WRITE failed: Interrupted system call
    NVMAP_IOC_WRITE failed: Interrupted system call
    NVMAP_IOC_WRITE failed: Interrupted system call

Any ideas on what I could be doing wrong?

Thx,
Y-

Hi Yile,

We can play mp4 file with below command:

gst-launch-1.0 filesrc location=<filename.mp4> ! decodebin name=dec ! nvvidconv ! autovideosink dec. ! audioconvert ! autoaudiosink -v -e

We don’t know what’s y4m file, please try this command to play your *.y4m file.

Corresponding thread found: https://devtalk.nvidia.com/default/topic/1004977/vlc-not-working-on-l4t-r27-0-1-/?offset=12

The *.y4m file is a raw 420 format video file.

Hi Yile, please share how to generate y4m files. And gstreamer commands without NVIDIA plugins can play it. We don’t have experience on this and please share more detail. Thanks.

Another user has given the suggestion:
https://devtalk.nvidia.com/default/topic/1012401/jetson-tx2/capturing-raw-video-using-gstreamer/post/5163071/#5163071