Gstreamer lag increases with frame rate recording from Raspberry Pi camera (nvarguscamerasrc and nvivafilter)

Hi,
Please execute the steps to run system at maximum performance mode. And check if there is improvement:

  1. Run $ sudo nvpmodel -m 0 and $ sudo jetson_clocks
  2. Set the property to hardware encoder:
  maxperf-enable      : Enable or Disable Max Performance mode
                        flags: readable, writable, changeable only in NULL or READY state
                        Boolean. Default: false
  1. Enable VIC engine at maximum clock:
    Nvvideoconvert issue, nvvideoconvert in DS4 is better than Ds5? - #3 by DaneLLL

You can check CPU/GPU/NVENC status by executing sudo tegrastats

1 Like