Gstreamer play 4k video

Hi Nvidia Experts,
We are currently testing 4K video playback on the JETSON AGX ORIN DEVELOPER Kit with r36.2.
Our tests involve using both the default video player and GStreamer(Accelerated GStreamer — NVIDIA Jetson Linux Developer Guide 1 documentation).
The test results are as follows:

Ubuntu Video Player:

  • VP9: Video playback is stuck.
  • AV1: Video playback is stuck.
  • H264: Video playback is not smooth.


  • VP9: Videos cannot be played back.
  • AV1: Videos cannot be played back.
  • H264: Video playback is not smooth.
    The GStreamer test commands and logs as videos_log.txt .
    videos_log.txt (6.0 KB)
    The videos full information as videos_detail.txt .
    videos_detail.txt (20.0 KB)

Could you help to determine why VP9 and AV1 videos cannot be played using GStreamer?
Additionally, could you investigate why H264 video playback is not smooth?

Hi Nvidia Experts,
We subsequently used ‘sudo jetson_clocks’ and nvgstplayer-1.0 for 4K video playback testing.

Test commands:
sudo jetson_clocks
nvgstplayer-1.0 -i filename.mp4


  • VP9: Videos seems fine.
  • AV1: Video playback is not smooth.
  • H264: Video playback is not smooth.
    Could you investigate why AV1 and H264 video playback is not smooth?

Please run the script to also enable hardware converter at maximum clock:
VPI - Vision Programming Interface: Performance Benchmark

And set --no-sync to disable synchronization mechanism in gstreamer:

$ nvgstplayer-1.0 -i test.mkv --no-sync --stats

Hi DaneLLL,

“sudo ./ --max” and “nvgstplayer-1.0 -i test.mkv --no-sync --stats”

  • VP9:Video playback seems fine.
  • H264: Audio is out of sync, video appears to be playing at a faster speed than usual.
  • av1: Audio is out of sync, video appears to be playing at a faster speed than usual.

“sudo ./ --max” and “nvgstplayer-1.0 -i test.mkv --stats”

  • VP9:Video playback seems fine.
  • H264:Video playback is not smooth.
  • AV1:Video playback is not smooth
    Logs as attachment “Log.txt”.
    Log.txt (16.9 KB)

According to the test result, even the “–no-sync” let playback smooth, but it caused new issue about “playback speed” and “audio not sync”.
Do you have any further suggestions?

Hi DaneLLL,
I used Jetson Power GUI to record CPU,GPU usage for both of “sync” and “–no-sync”.
It seems the “–no-sync” will use more CPU and GPU than “sync”.
Does it possible to increase CPU and GPU usages without “–no-sync” parameter?

Raw Data:
nosync_av1_cpu_gpu.csv.txt (139.4 KB)
sync_av1_cpu_gpu.csv.txt (141.7 KB)

Is the TV in 4Kp60 mode? And do you use AGX Orin developer kit with DP output?

Yes, The TV is 3840*2160p@60Hz mode.
I use AGX Orin developer kit, but the DP output connect to HDMI convertor to TV.
I also use our board(HDMI output) to test, the result are same.

Could you try the TV with DP output? To eliminate the converter and see if it can achieve the target performance.

I used AGX Orin developer kit with 2k,4k DP screen to test, the results are same as HDMI converter.
Also, our board is followed desisgn guide.

So we assume the 4K video playback should be fine in our board with HDMI output.

Hi DaneLLL,
Could you kindly attempt to reproduce this issue with the EVB?
Also, may I inquire if there are any updates?

We try the video file on AGX Orin developer kit + DP output with Jetpack 5.1.3, and the frame rate is close to 60fps:
the left-top video file:

$ nvgstplayer -i 18284892-uhd_3840_2160_60fps.mp4 --stats

Could you try the video file? Would like to see if you can get target frame rate while playing the same video.

Hi DaneLLL,
The 18284892-uhd_3840_2160_60fps.mp4 seems fine.
We tested other 60fps videos, and their playback was smooth as well.
However, I found that some videos with a resolution of 3840x2160 at 23.98fps do not play smoothly.
For example:

Could you please help to investigate why videos with a lower fps don’t have smooth playback?

It may be due to unique frame rate of the video file. We will check further.

Common 4Kp60 video files should be played fine.

Hi DaneLLL,
Any update about low fps videos latency issue?

We will set up and check. It looks to be the frame rate is unique and AV synchronization may be triggering the issue. Would need to check if there is a display mode which fits the frame rate to avoid the mismatch.

We try it with TV setting to 4K 23.98fps mode and do not observe laggy video playback. If your TV supports the mode, please switch to the mode and give it a try.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.