GStreamer v1.18.5 Support on Nano

We are developing a SRT video encoder. In order to pass the stream ID, GStreamer version 1.18.5 is required. But we can’t compile it on Jetpack v4.6.1. It only supports GStreamer v 1.16.3. May I know any support plan of GStreamer version 1.18.5 on Nano?

Hi,
For r32 releases(Jetpack 4) the gstreamer version is 1.14.5. Please refer to instruction in gstreamer user guide to manually build the gstreamer packages. The deviation in header files between 1.14.5 and 1.18.5 can be significant so please also rebuild our plugins. The plugins are open source and in the package:
Jetson Linux | NVIDIA Developer
L4T Driver Package (BSP) Sources

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.