GstRTSPSrc:rtspsrc0: Could not read from resource

Please provide complete information as applicable to your setup.

• Hardware Platform (Jetson / GPU)
Jetson Nano & Jetson Xavier
• DeepStream Version
5.0
• JetPack Version (valid for Jetson only)
4.4
• TensorRT Version
7.1.3
• Issue Type( questions, new requirements, bugs)
When running my GST Pipeline on my Jetson nano, the connection to the IP camera gets lost after around 30-40 seconds.
I was wondering if maybe that was a processing issue from my Nano and so I tried the same pipeline on my Xavier. The issue is the same.
Thus my question: is this a normal behavior ? Shouldn’t the pipeline reconnect to the RTSP stream by itself ?
• How to reproduce the issue ? (This is for bugs. Including which sample app is using, the configuration files content, the command line used and other details for reproducing)
Here’s the pipeline I am using

gst-launch-1.0 -e rtspsrc location=rtsp://user:pwd@ip:port ! rtph264depay ! h264parse ! omxh264dec ! omxh265enc ! mp4mux ! queue ! filesink location=output.mp4

Hi,
It looks to be instability in the source. Please check if you can see smooth video playback in running:

gst-launch-1.0 uridecodebin uri=rtsp://user:pwd@ip:port ! nvoverlaysink

This is a really old issue and I’m sorry for the bump but I solved it. The problem didn’t come from GStreamer but from my RTSP camera that had an instability when using UDP.

I fixed it by setting the uri to rtspt:// and not rtsp://