GT 430 VGA-430-A1 vdpau

Hello NVIDIA-folks!
Having trouble with getting vdpau working, currently I’m on debian wheezy 64.

libva: VA-API version 0.32.0
Xlib: extension "XFree86-DRI" missing on display ":0".
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so
libva error: /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so init failed
libva: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

seams to be in the correct location:
lrwxrwxrwx 1 root root 18 Mar 20 2012 /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so -> vdpau_drv_video.so
-rw-r–r-- 1 root root 101152 Mar 20 2012 /usr/lib/x86_64-linux-gnu/dri/vdpau_drv_video.so

xorg.conf http://paste.debian.net/239477/
glxinfo http://paste.debian.net/239478/
Xorg.0.log http://paste.debian.net/239479/
lsmod http://paste.debian.net/239480/

Hope I can get some helps with this, cause the reason I bought the gfx was that it claimed to support vdpau.
This is the specific card in question: http://www.pointofview-online.com/showroom.php?shop_mode=product_detail&product_id=279
I did also send an email to Point of View, but no reply.
Thank you for taking the time to look into this

//Jon-Eric Wallin

What video player are you using? It looks like you’re using something that wraps VA-API around VDPAU. Does it work with a player that has built-in VDPAU support like mplayer2?

Trying to use XBMC at the moment, but can’t get the system to utilize it (libva doesn’t load the module). I will try with mplayer2 and I’ll get back to you, but my assumption is that it also needs libva to render.

Yupp, as I suspected; same problem.

Maybe this solves your problem?

http://forum.xbmc.org/showthread.php?tid=116825

vdpau != vaapi

Get and run vdpauinfo.

isplay: :0 screen: 0
VDPAU capture: Enabled
vdp_imp_device_create_x11(0x1404010, 0, -, -)
VDPAU nvidia: Version: NVIDIA VDPAU Driver Shared Library 304.64 Tue Oct 30 11:20:48 PDT 2012
VDPAU nvidia: Error detected 10 296 5
VDPAU nvidia: Backtrace:
–: /usr/lib/x86_64-linux-gnu/vdpau/libvdpau_nvidia.so.1 [0x7f11dc40c000] DSO load base
00: /usr/lib/x86_64-linux-gnu/vdpau/libvdpau_nvidia.so.1 [0x7f11dc44620b]
01: /usr/lib/x86_64-linux-gnu/vdpau/libvdpau_nvidia.so.1 [0x7f11dc43503a]
02: /usr/lib/x86_64-linux-gnu/vdpau/libvdpau_nvidia.so.1 [0x7f11dc4160bc] vdp_imp_device_create_x11
-> 1
Error creating VDPAU device: 1

create symblink from ln -s /usr/lib32/libvdpau_nvidia.so.304.64 nvidia_drv_video.so
just downgraded the driver to try an older one, same problem was with experimental.

interesting idea with xvba, but I have an nvidia card and not an ati :/

A bit more fiddeling and I’m down to a known error which claims to be fixed in the version I’m using of libva, but I’m not sure sure it’s actually fixed:

libva: VA-API version 0.32.0
Xlib: extension “XFree86-DRI” missing on display “:0”.
libva: va_getDriverName() returns 0
libva: Trying to open /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so
libva error: /usr/lib/x86_64-linux-gnu/dri/nvidia_drv_video.so has no function __vaDriverInit_0_32
libva: va_openDriver() returns -1
vaInitialize failed with error code -1 (unknown libva error),exit

has no function is referred to in a bug, in the previous package, dont think it’s solved :/
Not sure if the bios on the gt 430 can be flawed? Sent a mail to Point of View, according to them it didn’t need flashing. Googled a bit and found nvflash, I have no experience from it, prolly wont help me at this stage?

Well, what can I say; been trying to get this to work around the clock. Would be great if some developer can confirm if this card isn’t capable of vdpau/vaapi anymore, as I previously mentioned I bought the card based on those properties and it frustrates me that I can’t make it work. Installed drivers via nvidia.com again and here is the output, hope it helps developers, cheers!

glxinfo http://pastebin.com/YMZt4dcr
lshw http://pastebin.com/b1ujAJnt
lsmod http://pastebin.com/3q44vrtA
lspci http://pastebin.com/4JkS8yDh
modinfo nvidia http://pastebin.com/UTQgps4H
vainfo & vdpauinfo http://pastebin.com/8x79TmnB

The card definitely does support VDPAU, your issue I’d say is you made a mess of your system installing different nvidia drivers using different installation methods. Which means you have conflicting files at possibly incorrect locations. An Arch user had similar though not quite the same issue recently. His solution was forcing a reinstall of libvdpau.

Right now, it’s impossible to know what the state of your machine is, which driver files you have installed where, and whether it’s possible to clean the mess up without reinstalling the whole system. You’d need to make sure no nvidia files are anywhere on the system, then reinstall the driver using distro packages.

Same error if I run aptosid, squeeze or any of the live* tried most of them; system is intact. Also tried both 32/64, however I don’t know how far the issue extends, even thought about sandy-bridge might be the cause. Haven’t read any “bad” reviews about the mobo, one suggestion might be the bridge.

It does seem like some kind of configuration issue.

I’m perplexed about why VA-API is being brought into the mix. That’s something used for Intel / AMD hardware or for software that doesn’t support VDPAU (e.g., VLC). Is it trying to render to the Sandy Bridge iGPU? I could be off on this though… it’s always been so seamless for me that I can’t be sure what’s going on behind the scenes.

That’s my final thought too, been mostly seamless before; but now I’m tearing my hair. Although I’ve got the iGP turned off; I’ve not the knowledge to say that sandy doesn’t cause disturbance. Just got home so I will continue my quest now again, had to take a break ;)
It makes it more interesting that there are no reports in the error I receive from vdpauinfo (VDPAU nvidia: Error detected 10 301 5) seams like it’s new.
Card is still what’s in the topic, driver loads fine, but error is detected by libva and doesn’t load. Would be awesome if some developer from nvidia could look at this error, if it’s faulty card or just drivers :/

Tried today switching between the pci-e slots, same error occurs; still thinking it can be sandy-bridge that causes the anomaly, or I’ve just run out of ideas. Although it’s also mentioned as a “fully supported” in the kernel.

Why do you think Sandy Bridge interferes? What about it would interfere? The only thing that maybe could is the iGPU, but you’ve turned that off.

I don’t think this is a hardware problem. It’s an installation/configuration issue. But like I already said, it’s impossible to know the state of your machine, so it’s impossible to say what’s not right.

Edit: Or it could actually be a hardware issue: http://70.87.46.147/vbulletin/showthread.php?p=2532765 <- leads me to believe Point Of View screwed something up. So return the card and get one from a different manufacturer.

Check Nvidia’s README, for file locations, to cleanup. A useful one-liner to find many Nvidia files:

find /usr/lib* -iname libnv*

submitted nvidia-bug-report.log.gz
nvidia-bug-report.log.gz (76.1 KB)

Problem solved, turns out the GT 430 by Point of View doesn’t support VDPAU under Linux. Problem was solved while buying gtx 660 2gb.

Thank you all for looking into this problem, much apriciation to all who tried to help!