GTX 1650 - Linux Mint 20 - black screen with blinking cursor just before login screen

I bought an Asus Nvidia GTX 1650 to upgrade a GeForce GT 640 ( which works fine.)
I definately have the video-out plugged into the card, not the motherboard.
The boot up is visible, and proceeds as expected until just before the login prompt. Then the screen is black, but periodically a white cursor will flash or stay still in the upper left corner, disappear, come back, as if the system it trying different things. It never gets to login.

Looking at the logs, the /var/log/Xorg.0.log.old says:


129.397] (II) NVIDIA GLX Module 440.100 Fri May 29 08:19:01 UTC 2020
[ 129.397] (II) NVIDIA: The X server supports PRIME Render Offload.
[ 133.396] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA GPU at PCI:2:0:0. Please
[ 133.397] (EE) NVIDIA(GPU-0): check your system’s kernel log for additional error
[ 133.397] (EE) NVIDIA(GPU-0): messages and refer to Chapter 8: Common Problems in the
[ 133.397] (EE) NVIDIA(GPU-0): README for additional information.
[ 133.397] (EE) NVIDIA(GPU-0): Failed to initialize the NVIDIA graphics device!
[ 133.397] (EE) NVIDIA(0): Failing initialization of X screen
[ 133.397] (II) UnloadModule: “nvidia”
[ 133.397] (II) UnloadSubModule: “glxserver_nvidia”
[ 133.397] (II) Unloading glxserver_nvidia
[ 133.397] (II) UnloadSubModule: “wfb”
[ 133.397] (II) UnloadSubModule: “fb”
[ 133.397] (EE) Screen(s) found, but none have a usable configuration.

The /var/log/kern.log has many lines that say:
Jul 13 15:48:49 timb-desktop kernel: [ 133.397023] NVRM: GPU 0000:02:00.0: RmInitAdapter failed! (0x24:0x65:1185)
Jul 13 15:48:49 timb-desktop kernel: [ 133.397100] NVRM: GPU 0000:02:00.0: rm_init_adapter failed, device minor number 0

The system details are:
Linux Mint 20, Cinnamon
kernel = 5.4.0.26-generic
motherboard: ASRock N68S ucc
driver Nvidia 440 (440.100-0ubuntu0.20.04.1
display LG Electronics E2260 (DVI-D-0) 1920x1080

I have been reading forums and trying to get it to work for a week. I’ve purged and re-installed the drivers. I’ve tried older drivers, I tried the open-source nouveau drivers. I’ve tried the “nomodeset” parameter in the grub config, , I’ve tried generating a custom /etc/X11/Xorg.conf file with the nvidia-xconfig utility, I tried booting up from Mint 18.3, and from Ubuntu 20.04.

In all cases, the old GT-640 graphics card works fine, but the new GTX-1650 gives exactly the same problem.

I took it back to where I bought it, and they plugged it into a windows 10 PC and it worked. So I can’t return it. It also shows that it isn’t broken - it must be some configuration problem, but I’ve no idea what to do next. I’m not a computer tech, I’m just googling stuff and trying it out.

Any ideas would be welcome.

The nividia bug-report follows, but it is for the GT-640 card, since I can’t boot with the new one.

nvidia-bug-report.log (1.2 MB)

Tried with a different motherboard and there is no problem.

I would close this with the note that the
ASRock N68S ucc motherboard is incompatible with the
Nvidia GTX 1650 graphics card.