[GTX 1650 Mobile] Driver stopped working

Last night my laptop’s graphics driver stopped working and I can’t figure out why.

I am running Ubuntu 22.04 LTS, and I was using the nvidia-driver-525 package at the time. Upon reboot however, my laptop would freeze before graphics mode started (I had a black screen with a grey cursor in the top left corner that stopped blinking after a few seconds, and then froze). I was able to enter tty mode and could use prime-select to fall back to my integrated GPU, so I can still access my system relatively normally.

I had a similar issue a few months ago when I tried installing some GPU libraries (I think it was tensorflow) and I might have accidentally broken something at the time. Back then I also fell back to my iGPU for a week or so but after reinstalling the nvidia drivers from scratch my system worked normally again.

Based on similar issues I could find via googling and my own past experience, I have tried purging all nvidia packages and installing nvidia-driver-515 (yes, that is an earlier version from what I was using before, I am aware and that was on purpose) from scratch, but that does not seem to work and the situation remains the same.

If anyone can help me figure out (mostly where to look for the issue), I could gladly use any help!

Attached is my nvidia bug report log. Based on some similar threads (that did not solve my problem) I can also provide:

~$ dkms status
nvidia/515.65.01, 5.15.0-57-generic, x86_64: installed

~$ nvidia-smi
NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver. Make sure that the latest NVIDIA driver is installed and running.

During boot, the splash text warned it could not (among others) launch the nvidia persistence daemon. Sysctl does not give me meaningful information, but for the record:

~$ sudo systemctl status nvidia-persistenced.service
× nvidia-persistenced.service - NVIDIA Persistence Daemon
     Loaded: loaded (/lib/systemd/system/nvidia-persistenced.service; enabled; vendor preset: enabled)
     Active: failed (Result: exit-code) since Sat 2023-01-07 12:13:08 CET; 15min ago
    Process: 990 ExecStart=/usr/bin/nvidia-persistenced --verbose (code=exited, status=1/FAILURE)
    Process: 994 ExecStopPost=/bin/rm -rf /var/run/nvidia-persistenced/* (code=exited, status=0/SUCCESS)
        CPU: 5ms

Jan 07 12:13:08 ***** systemd[1]: nvidia-persistenced.service: Scheduled restart job, restart counter is at 5.
Jan 07 12:13:08 ***** systemd[1]: Stopped NVIDIA Persistence Daemon.
Jan 07 12:13:08 ***** systemd[1]: nvidia-persistenced.service: Start request repeated too quickly.
Jan 07 12:13:08 ***** systemd[1]: nvidia-persistenced.service: Failed with result 'exit-code'.
Jan 07 12:13:08 ***** systemd[1]: Failed to start NVIDIA Persistence Daemon.

If I can provide more information, I’d be happy to do so! Any suggestions or pointers are appreciated.

nvidia-bug-report.log.gz (150.2 KB)

The driver seems to be blacklisted. Please try:

  • run
sudo prime-select nvidia
  • run
grep nvidia /etc/modprobe.d/* /lib/modprobe.d/*

to find a file containing

blacklist nvidia

and remove it,
then run

sudo update-initramfs -u

and reboot.

Hi, thanks for the quick reply.

Unfortunately, this did not work for me.

After grep-ing for nvidia blacklists, the only blacklist I found was the one generated by nvidia prime (presumably because I switched to my intel iGPU).

Running sudo prime-select nvidia means the blacklist disappears, but it also causes the issue to re-appear immediately (the screen turns black as if it is trying to restart my graphics driver, then the cursor blinks a few times and then freezes without graphics ever appearing. TTY is the only way to get access to my laptop at that point).

I might have accidentally uploaded a wrong error log in that case. For completeness, I have added the error log with the prime nvidia profile here.

nvidia-bug-report.log.gz (330.2 KB)

Please remove nomodeset kernel parameter.

1 Like

Thank you so much, that worked!

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.