GTX 285 hdmi audio passthrough

So my card is pre-Azalia so the how-to doesn’t help:

ftp://download.nvidia.com/XFree86/gpu-hdmi-audio-document/gpu-hdmi-audio.html

I have nothing in aplay -l regarding the gpu, and I can’t find an nvidia-settings knob to turn to try to enable the passthrough. I can boot into windows and it works pretty much out of the box and shows up as audio to output in the control panel. Outputting to the onboard audio SPDIF PCM goes to the back of the board SPDIF port. It might also go to the onboard spdif header passthrough cable, but I wouldn’t be able to tell.

So how can I get pre-Azalia passthrough working on a gtx 285?

if is pre-azalia, need wire connected from motherboard SPDI-F jumpers to Graphic card




(each motherboard have different connector in motherboard. find connector by you mobo Guide book)

i have a Zotal GTX285, this not have a soundcard integrate in the graphic card, need the wire

Yes, I have the wire. It works fine under Windows. Nothing shows up in nvidia-settings, aplay, or /dev/snd referring to the gpu or audio passthrough. In case it matters, the board is a p6t deluxe v2.

How did you get the output device to show up?

i not have wire (no need audio passthrough)

but what happen if in alsa select the SPID-F output? or unmute in alsamixer

see http://alsa.opensrc.org/DigitalOut

or use pulseaudio

Very odd. If I use the pulseaudio iec958 sink, playback works. Speaker-test on iec958 doesn’t, though. It might just not be default to the right sink.

Oh well, it works. Thanks for the advice.