GTX 480 on Ubuntu 9.04 probe failed

Hey guys,
I just got a GTX 480 and the system (Ubuntu 9.04 with gcc 4.3) is not able to recognized it.

In the dmesg I get:
NVRM: The NVIDIA GPU 05:00.0 (PCI ID: 10de:06c0) installed
NVRM: in this system is not supported by the 195.36.15 NVIDIA Linux
NVRM: grphics driver release.

Any idea?
Crepatas

Use 195.36.24:

http://www.nvnews.net/vbulletin/showthread.php?p=2239062

(I don’t really know why the early drivers are handled that way for Linux but that seems to be the place to get them)

Thanks for your prompt reply, unfortunately I still get the error:

NVRM: The NVIDIA GPU 05:00.0 (PCI ID 10de:06c0) installed

NVRM: in this system is not supported by the 195.36.24 NVIDIA Linux

NVRM: graphics driver release.

NVRM: the NVIDIA probe routine failed for 1 device(s).

NVRM: loading NVIDIA UNIX x86_64 Kernel Module 195.36.24

if I only have the GTX 480 then my P6T7 board signals no VGA detected (one long beep followed by 3 fast ones). I can read the error if a GT 9500 drives the monitor. I don’t think I have problem of power supply since I have 1.5kW PSU. My default system is 2 card GTX 280 and a GT 9500 for the monitor. I’d like to substitute the GTX280s for GTX480.

Any idea?

Thanks

Crepatas

I also have the P6T7 WS revolution board, and my 2x GTX480 works with drivers 195.36.15. It’s not 100% working, in that nvidia-settings does not properly recognize the clocks on the card (it says it’s 0 MHz) but CUDA examples run with no problem, and my code does as well. However, the previous drivers from December did NOT work… cards recognized, but the GTX480 won’t run CUDA examples. (2D graphics seemed OK). The previous generation of drivers (193.x?) did not see the GTX480 at all.
I have not tried today’s new 195.36.35.

I have also run GTX470 and GTX295 and GT240 and GTX280 and FX3800 in that same motherboard with the same OS and driver. (Yes, I leave a screwdriver on top of my case!)

I don’t know if it really mattered or not, but when first trying to get the GTX4XX cards working, I kept having trouble and I finally reinstalled the driver (even though it was already installed) and also wiped the xorg.conf file away completely. It may not have mattered, but I finally did get the cards working, and I think the driver reinstall may have helped.
Can’t hurt to try, though your 195.36.24 install would have done the same thing. Did you install that while the GTX480 was in the machine?

I do know that in WINDOWS it’s really important to install the drivers with the cards actually in the machine. It doesn’t like you adding new cards later… it can work but it can also fail. It will claim it’s reinstalling drivers itself and then ask you to reboot, but that self-reinstall doesn’t seem to do the same as when you launch the driver install yourself. That may be why I feel the driver reinstall in Ubuntu helped me too.

Just as an FYI, I’ve just installed 195.36.24 and still experiencing, as SPWorley, the 0Mhz GPU clock.

Almost certainly related, you also cannot set the device clocks either by the GUI or the command line interface.

I tried on both the GTX480 and GTX470.

G200 cards do allow setting the shader clocks by setting their xorg.conf coolbits value to 1, if and only if the device has the 5 second watchdog kernel killer limit active. You can check for this by using the cudaGetDeviceProperties API call and looking at the kernelExecTimeoutEnabled flag. If it’s set, then the device’s clocks can be modified. There are two workarounds to this limitation… use Windows (which has no restrictions) or rewrite the device’s onboard BIOS chip with new firmware.

i my slef have went on the Ubuntu forms asking for a drive for the gtx480 on the 9.04, all I got was them telling me to upgrade to Ubuntu 14.