GTX 550 ti driver not working Ubuntu 20.04

Hi, I am trying to make an old GTX 550 ti card on Ubuntu 20.04.
If I use
lspci | grep VGA
I can see the card
01:00.0 VGA compatible controller: NVIDIA Corporation GF116 [GeForce GTX 550 Ti] (rev a1)
and also my monitor is connected to it so the card works, but the driver doesn’t seem to be working correctly.

In the Software&Updates window I can see that its installed ( the version 390) but if I do
It says that I don’t have a driver.

What I have tried until now:

  • uninstall the driver with
    sudo apt --purge remove nvidia*
    and install the older version 390 (by default it was 460) which did nothing.

  • I tried to install the version 340 but it caused a black screen after reboot.

  • I have seen this thread so I tried creating the xorg.conf file, but it did nothing.

  • I also ran the report
    nvidia-bug-report.log (1.3 MB)

  • I ran
    without success.

Also I didn’t want to blindly try everything in that link as I don’t completely understand it and I don’t know if it applies to my case.

If anyone could point me on the right direction to solve this problem I would appreciate it.

The problem is there’still a 460 kernel driver stuck in the initrd. Please post the output of
dkms status

Thank you for your attention to my problem. This is the output to dkms status:
nvidia, 390.141, 5.8.0-48-generic, x86_64: installed (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!)

Please try:
sudo dkms remove nvidia/390.141
sudo dkms install nvidia/390.141 --force
sudo update-initramfs -u

Hey! That totally worked!
Thank you very much for your help.
Have a good day/evening/night!