GTX 660ti, Linux, Poor performance, constant lags and shutters

Hello, I am dealing with this since I remember. I don’t know if it’s only my card, all 660ti, or what.
Every distribution that I have used, every animation is laggy and slow.

Slow scrolling in internet browsers, low fps animations in Gnome 3, KDE, and it’s just sad.
I see people using integrated intel graphics, and their animations are much smoother.

I am currently running nvidia-1:361.42-1.

Sublime scrolling: https://www.youtube.com/watch?v=RyOJu6Ze5vQ
And no, it’s not only sublime problem. I just don’t use more programs with animations because of this troubles, but I’d like to…

https://konradb.net/files/public/inne/nvidia-bug-report.log.gz

From your dmesg:

[   27.999776] NVRM: Your system is not currently configured to drive a VGA console
[   27.999779] NVRM: on the primary VGA device. The NVIDIA Linux graphics driver
[   27.999781] NVRM: requires the use of a text-mode VGA console. Use of other console
[   27.999782] NVRM: drivers including, but not limited to, vesafb, may result in
[   27.999783] NVRM: corruption and stability problems, and is not supported.

And a 2nd problem:

/sbin/nvidia-smi -q

Failed to initialize NVML: Driver/library version mismatch

I have fixed those problems. But there was no improvement in performance.

https://konradb.net/files/public/inne/nvidia-bug-report_2.log.gz

You also have:

[    29.906] (II) x11glvnd: X server major video driver ABI mismatch: expected 20 but saw 19

Have you deliberately downgraded xorg-server from 1.18.x to 1.17.x?

how fix the first problem?

GRUB_TERMINAL_INPUT=console
GRUB_TERMINAL_OUTPUT=console
GRUB_GFXMODE=auto
GRUB_GFXPAYLOAD_LINUX=keep

Don’t remember which one exactly, bu I have those.

I don’t know, I was reinstalling drivers etc. :o