GTX 680, cannot get rid of tearing Q_Q

Hello,

After 3 days of Google search with no luck, Maybe one of you could fix my issue.

Got ArchLinux 64, Xfce + Compiz on both laptop (GTX 680) and laptop (GT 555M).
Nothing to say, no bugs with 319.49 on the laptop : everything runs smoothly, NO TEARING AT ALL.

But on my desktop, I can’t get rid of tearing that is located at the top of the screen. Ive tried 304 319 325 331 drivers, nothing changes. I’ve tried with another monitor, same tearing at the top of the screen. I’ve tried diffrent nvidia-settings stuffs, no way…

Both desktop and laptop run linux 3.10.19

Now, I just don’t know what to do… Please help me

Feel free to ask whatever you need to fix the issue

I really thank you,

Nad

One information :

If I choose, in nvidia settings, resolution 1920x1080@50Hz, tearing disappears…

Not sure if, but from your description I think you may suffer the same issue like being discussed in these, even they mostly about tearing in xv / flash videos:
https://devtalk.nvidia.com/default/topic/525640/linux/evga-geforce-gtx-660-ti-problems-/
and here
https://devtalk.nvidia.com/default/topic/543305/screen-video-tearing-gtx-6xx-7xx-titan-in-almost-all-applications-including-desktop-itself/

A newer discussion with a workaround is here, maybe have it a try, but it has a bit impact on performance:
https://devtalk.nvidia.com/default/topic/618559/linux/xv-is-tearing-in-331-13/

Thank you,

I’m at work for now and will try the workaround this week end (tomorrow).
As far as I understodd (but I read quickly) it’s due to Kepler architecture ?

What’s weird is that after login, if I open xfce4-terminal and start moving it (with compiz fusion), I have NO TEARING at all, even if I don’t stop moving it during 5 minutes. Let’s say, I move it during 5 minutes : no tearing, I’m happy ;) . It stop. I wait for 1 second. I move it again and then… that’ horrible huge tearing is there.

It seems to be cyclic as regards videos (vlc vdpau), it can play 1 minute without wny tearing, then teaing for 1 minutes, then no, etc…

Hope the workaround will work !

Oh… I forgot to say :

My Dell U2410 monitor resolution is 1920x1200 60Hz.

If, with nvidia-settings, I set it to 1920x1080 50Hz, that’s the end of this annoying tearing !!!

But this is NOT a solution…

If anyone knows if I can force 1920x1200 50Hz, please tell me, I didn’t found out how to, and this may be only for testing purpose…

I’ve tested the fix :

Option “metamodes” “nvidia-auto-select +0+0 { ForceFullCompositionPipeline = On }”
in the screen section.

but only for 3 minutes -didn’t have more time-. During those 3 minutes, NO tearing !!!

I’ll let you know this week-end

Thanks !

nadstaky,
Please provide nvidia bug report, reproduction steps in detail, what desktop env you are using? Is this issue repro when composite disabled and desktop effects disabled ? What video player you are using ? Are you observing desktop tearing OR video tearing ? Is it possible to share repro issue video recording? Also share video clip on which you are observing tearing? Make sure nouveau and vesafb drivers are disabled.