GTX 860M stuck at 33 MHz after suspend

Whenever I put my laptop into suspend mode, and wake it back up, the GTX 860M card gets stuck running at 33 MHz. The same thing also happens when I unplug the power cable. It becomes extremely laggy and I can barely move my mouse. This is very annoying since I constantly move my laptop around and sometimes have rendering jobs in the background. I also have to either shut down the laptop at night or turn off suspending completely. I believe this issue started happening since the 340 drivers. Restarting Xorg, changing power states, over/underclocking does not work. PowerMizer is set to “Prefer Maximum Performance”.
AFTER_SUSPEND-nvidia-bug-report.log.gz (313.4 KB)

i use arch btw
tried 515-520 drivers, 5.18.0-6.0.1 kernels, all had the same

Please check for a bios update.

Updated to the latest available (E16GFIMS.52D), still the same issue

Looks like a lot of MSI notebooks (and some Dell) of that time were hit by the same bug and nobody found a fix for it.
Please check if setting kernel parameter
acpi_osi=! acpi_osi=“Windows 2009”
has an influence.

Nope, same issue.
Only thing that changed was my screen brightness which seemed to be stuck at a high brightness.
Also tried “Windows 2012”, “Windows 2015”, all the same…

So I guess there really is no solution?
Been contacting NVIDIA (linux-bugs) several times and they haven’t said anything…

I don’t think so,

        HW Slowdown                       : Active

seems the system’s firmware is pulling the brake.

Well, Windows doesn’t have this issue so I don’t know if NVIDIA fixed it in their drivers or Windows “patched” something in the firmware…

Thanks for your help though 😄

Not necessary anything was patched in the windows driver, it’s often that notebook manufacturers build their firmware just barely good enough that it works relying on the behaviour of a specific driver and Windows version. E.g. many hybrid graphics notebooks designed for Windows 7 were rendered useless when Microsoft changed Windows behaviour with Win 10 1709. While yours seems to work still fine with Win 10, it seems to have enough quirks so it doesn’t really work with Linux.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.