GTX 950 not detected on macOS with CUDA 7.5

I installed CUDA 7.5 on my Mac running macOS 10.12.1 with a GTX 950 with driver version 10.13.68 (367.15.10.15f03). As I understand, that meets the minimum driver specifications for CUDA 7.5. On the other hand, the install package was intended for OS X 10.11; 10.12 isn’t available for 7.5. I did have to install Xcode 6.2 and use Xcode-select redirect to an older, compatible version of nvcc/apple clang in order to compile the samples. CUDA doesn’t seem to detect the graphics card when I run deviceQuery.

./deviceQuery Starting...

 CUDA Device Query (Runtime API) version (CUDART static linking)

cudaGetDeviceCount returned 38
-> no CUDA-capable device is detected
Result = FAIL

Any ideas?

Edit: Problem ‘solved’ by updating driver to 8.0, then my card was detected no problem. However, I’m still having issues with my application that requires 7.5, and despite uninstalling the driver using the perl script and reinstalling from the 7.5 package, deviceQuery is still reporting CUDA Driver Version 8.0. Any help with that would be appreciated.