GTX 960 Low Resolution on second monitor in Fedora 24 with nvidia modules

Hey all,

After going from nouveau to nvidia drivers (which I will never do again after this point), my primary monitor is fine but the second monitor is at a lower resolution. When originally using the default nouveau drivers out of the box, the resolutions were as expected. In playing around with nvidia, I tried to go back to nouveau and ended up with the second monitor not receiving input with xorg logs complaining about EDID errors. Went back to nvidia drivers as I have at least a working monitor (though low resolution).

I am also having difficulty using nvidia-xconfig in so much that when I run it, log out, then log back in or reboot, the sad screen of “Oh no! Something has gone wrong” comes up. The only thing I have found to remedy this with my limited knowledge is a complete uninstall, reboot, and reinstall of the nvidia drivers and a rebuild of the initramfs. So I guess I technically don’t have an xorg.conf file?

Anyway, all I want at this point in time in Fedora 24 is 2 working monitors both at 1920x1080 resolution. If someone can figure out the nouveau issues, then awesome. If someone can figure out the nvidia issues, awesome. In either case, I just want to go back to 2 fully working monitors.

I am quite convinced at this point the issue is specific to the driver and how it interacts with the card for the following reasons:

  1. The monitor works fine in Windows
  2. Originally without tampering, nouveau could display on both monitors fine
  3. The nvidia installer/driver directly from their site has the same issue, but the max resolution is 640x480 on the second monitor
  4. Reinstalling the nouveau driver causes onlining of the second monitor to fail with EDID errors (which I can get if need be, it will just require uprooting everything so be patient)
  5. The 1024x768 resolution is seen only with the repofusion nvidia module

System info:
Xorg/Wayland info


EDIT Accidentally linked the System Info pastebin twice

From what I understand, nvidia propriatary drivers don’t work with wayland, because they refuse to patch wayland/weston with nvidia supplied patches.

Yeah I just tested it, your screen will go black as it does not work, you would need a patched weston/wayland. You can read the interaction between wayland/weston here,

Thank you for that input!

Unfortunately this doesn’t explain the EDID errors if I am to go back to Nouveau.